您的位置:首页 > 其它

hdu 5086 Revenge of Segment Tree(BestCoder Round #16)

2014-11-02 10:23 302 查看


Revenge of Segment Tree

                                                         Time Limit: 4000/2000 MS (Java/Others)    Memory Limit:
32768/32768 K (Java/Others)

                                                                                   Total Submission(s): 420    Accepted Submission(s): 180


Problem Description

In computer science, a segment tree is a tree data structure for storing intervals, or segments. It allows querying which of the stored segments contain a given point. It is, in principle, a static structure; that is, its content cannot be modified once the
structure is built. A similar data structure is the interval tree.

A segment tree for a set I of n intervals uses O(n log n) storage and can be built in O(n log n) time. Segment trees support searching for all the intervals that contain a query point in O(log n + k), k being the number of retrieved intervals or segments.

---Wikipedia

Today, Segment Tree takes revenge on you. As Segment Tree can answer the sum query of a interval sequence easily, your task is calculating the sum of the sum of all continuous sub-sequences of a given number sequence.

 

Input

The first line contains a single integer T, indicating the number of test cases. 

Each test case begins with an integer N, indicating the length of the sequence. Then N integer Ai follows, indicating the sequence.

[Technical Specification]

1. 1 <= T <= 10

2. 1 <= N <= 447 000

3. 0 <= Ai <= 1 000 000 000

 

Output

For each test case, output the answer mod 1 000 000 007.

 

Sample Input

2
1
2
3
1 2 3

 

Sample Output

2
20
HintFor the second test case, all continuous sub-sequences are [1], [2], [3], [1, 2], [2, 3] and [1, 2, 3]. So the sum of the sum of the sub-sequences is 1 + 2 + 3 + 3 + 5 + 6 = 20.
Huge input, faster I/O method is recommended. And as N is rather big, too straightforward algorithm (for example, O(N^2)) will lead Time Limit Exceeded.
And one more little helpful hint, be careful about the overflow of int.

 

求一段序列的所有连续子序列的和。
对于序列中的第i个,下标从0开始,在第ai个前有i+1个数(包括它自己),在ai个后有n-i个(包括它自己),所以ai
共出现(i+1)*(n-i)次。
 
*心累唉,考虑到是这样的思路,但是没能找出规律,每次的规律题都做不出来T-T    文章转载自http://blog.csdn.net/caduca/article/details/40706465

官方题解:

考虑每个数出现在多少个子序列之中,假设第i个数为Ai,区间为[L,R]。那么包含Ai的区间满足L⩽i⋂R⩾i。累加(L+1)∗(N−R)∗A[i]就可以了。

代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
long long mod=1000000000+7;
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
long long n;
long long ans=0;
long long a;
scanf("%I64d",&n);
for(int i=0;i<n;i++)
{
scanf("%I64d",&a);
ans=(ans+(((a*(i+1)%mod)*(n-i))%mod))%mod;
}
printf("%I64d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: