您的位置:首页 > 其它

hdu 5086 Revenge of Segment Tree

2014-11-01 22:57 375 查看
[align=left]Problem Description[/align]
In computer science, a segment tree is a tree data structure for storing intervals, or segments. It allows querying which of the stored segments contain a given point. It is, in principle, a static structure; that is, its content
cannot be modified once the structure is built. A similar data structure is the interval tree.

A segment tree for a set I of n intervals uses O(n log n) storage and can be built in O(n log n) time. Segment trees support searching for all the intervals that contain a query point in O(log n + k), k being the number of retrieved intervals or segments.

---Wikipedia

Today, Segment Tree takes revenge on you. As Segment Tree can answer the sum query of a interval sequence easily, your task is calculating the sum of the sum of all continuous sub-sequences of a given number sequence.

[align=left]Input[/align]
The first line contains a single integer T, indicating the number of test cases.

Each test case begins with an integer N, indicating the length of the sequence. Then N integer Ai follows, indicating the sequence.

[Technical Specification]

1. 1 <= T <= 10

2. 1 <= N <= 447 000

3. 0 <= Ai <= 1 000 000 000

[align=left]Output[/align]
For each test case, output the answer mod 1 000 000 007.

[align=left]Sample Input[/align]

2
1
2
3
1 2 3


[align=left]Sample Output[/align]

2
20
HintFor the second test case, all continuous sub-sequences are [1], [2], [3], [1, 2], [2, 3] and [1, 2, 3]. So the sum of the sum of the sub-sequences is 1 + 2 + 3 + 3 + 5 + 6 = 20.Huge input, faster I/O method is recommended. And as N is rather big, too straightforward algorithm (for example, O(N^2)) will lead Time Limit Exceeded.And one more little helpful hint, be careful about the overflow of int. 题意:计算一个整数序列所有子序列的和。 /*	题目叫做【线段树的复仇】,真是看呆我,其实是道找规律的题目	只要计算A[i]的出现次数,直接乘,然后相加就行。

至于出现次数,通过1-6个数的序列的各数字出现次数,每一斜行都是呈倍数递增的,第一斜行是1 2 3 4 5 6,第二斜行是2 4 6 8 10...	所以易得第n行的第i个数的出现次数为i*(n-i+1)。*/ 代码:[code]#include<iostream>
#include<stdio.h>
#include<cmath>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#define mod 1000000007
using namespace std;
__int64 d[447100];
int main()
{
//freopen("C:\\test.txt","r",stdin);
//freopen("C:\\res.txt","w",stdout);
int t;
__int64 i,n;
__int64 sum;
scanf("%d",&t);
while(t--)
{
sum=0;
scanf("%I64d",&n);
for(i=0;i<n;i++)
scanf("%I64d",&d[i]);
for(i=0;i<n;i++)
{
sum=sum+((((i+1)*(n-i))%mod)*d[i])%mod;
sum%=mod;
}
printf("%I64d\n",sum);
}
return 0;
}

[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: