您的位置:首页 > 其它

Revenge of Segment Tree (hdu 5086)

2014-11-01 21:10 399 查看

Revenge of Segment Tree

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1282 Accepted Submission(s): 324



Problem Description

In computer science, a segment tree is a tree data structure for storing intervals, or segments. It allows querying which of the stored segments contain a given point. It is, in principle, a static structure; that is, its content cannot be modified once the structure is built. A similar data structure is the interval tree.
A segment tree for a set I of n intervals uses O(n log n) storage and can be built in O(n log n) time. Segment trees support searching for all the intervals that contain a query point in O(log n + k), k being the number of retrieved intervals or segments.
---Wikipedia

Today, Segment Tree takes revenge on you. As Segment Tree can answer the sum query of a interval sequence easily, your task is calculating the sum of the sum of all continuous sub-sequences of a given number sequence.



Input

The first line contains a single integer T, indicating the number of test cases. 

Each test case begins with an integer N, indicating the length of the sequence. Then N integer Ai follows, indicating the sequence.

[Technical Specification]
1. 1 <= T <= 10
2. 1 <= N <= 447 000
3. 0 <= Ai <= 1 000 000 000



Output

For each test case, output the answer mod 1 000 000 007.



Sample Input

2
1
2
3
1 2 3



Sample Output

2
20
[code]HintFor the second test case, all continuous sub-sequences are [1], [2], [3], [1, 2], [2, 3] and [1, 2, 3]. So the sum of the sum of the sub-sequences is 1 + 2 + 3 + 3 + 5 + 6 = 20.
Huge input, faster I/O method is recommended. And as N is rather big, too straightforward algorithm (for example, O(N^2)) will lead Time Limit Exceeded.
And one more little helpful hint, be careful about the overflow of int.
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 1005
#define MAXN 2005
#define mod 1000000007
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

int main()
{
    int t;
    __int64 i,N,n,x,s;
    scanf("%d",&t);
    while (t--)
    {
        s=0;
        scanf("%I64d",&N);
        n=(N+1)/2;
        for (i=1;i<=N;i++)
        {
            scanf("%I64d",&x);
            if (i<=n)
                s=(s+(x%mod)*((N*i-(i-1)*i)%mod)%mod);
            else
                s=(s+(x%mod)*(( N*(N-i+1)-(N-i)*(N-i+1) )%mod))%mod;
        }
        printf("%I64d\n",s);
    }
    return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: