您的位置:首页 > 其它

Hduoj1686 【KMP】

2014-11-01 10:55 190 查看
/*Oulipo
Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5501    Accepted Submission(s): 2194

Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group.
 A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait 
voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’
intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où
 s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on
 some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these 
 occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence
  of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …,
 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive 
 characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W 
in the text T.

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
***ERDXIVYERDIAN
 

Sample Output
1
3
0
 

Source
华东区大学生程序设计邀请赛_热身赛 
*/
#include<stdio.h>
#include<string.h> 
char s[1000010], ne[10010];
int next[10010], len;
void getnext(int l)//深入理解    字符串最后一个结束符自动视为  失配时  next[len]= 字符串本身的最大相同前后缀 的下一个字符 
{
	next[0] = -1;
	int i, j;
	i = 0;
	j = -1;
	while(i < l)
	{
		if( j == -1 || ne[i] == ne[j])
		{
			i++;
			j++;
			if(ne[i]==ne[j])
			next[i] = next[j];
			else
			next[i] = j;
		}
		else
			j = next[j];
	}
}
int  main()
{
	int i ,j, k, m, n; 
	scanf("%d", &n);
	getchar();
	while(n--)
	{
		scanf("%s%s", ne, s);
		len = strlen(ne);
		k = strlen(s);
		getnext(len);
		m = 0;
		i = -1;
		j = -1;	
		while(i < k)//当i小于text串时 
		{
			if(j == -1 || s[i] == ne[j])
			{
				i++;
				j++;
			}
			else
			j = next[j];
			if(j == len)//暗藏杀机  一旦匹配成功长度加一  而子串的最后一个结束符必定不会和主串相匹配,
			m++;        //所以j = next[j]回到子串自身的最大相同前后缀的下一个字符 
		}
		printf("%d\n", m);
	}
	return 0;
}


题意:给定一个子串,求出子串在主串中出现的次数,标准的kmp算法。

难点:要理解kmp的next数组的具体含义
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: