您的位置:首页 > 其它

Keywords Search - HDU 2222 AC自动机

2014-10-31 13:48 330 查看


Keywords Search

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 36244 Accepted Submission(s): 11733



Problem Description

In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.

Wiskey also wants to bring this feature to his image retrieval system.

Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.

To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.



Input

First line will contain one integer means how many cases will follow by.

Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)

Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.

The last line is the description, and the length will be not longer than 1000000.



Output

Print how many keywords are contained in the description.



Sample Input

1
5
she
he
say
shr
her
yasherhs




Sample Output

3




题意:对于一个字符串,存在多少个关键字。

思路:AC自动机。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int next[500010][26],fail[500010],end[500010],L;
char s[1000010];
int newnode()
{
    int i;
    for(i=0;i<26;i++)
      next[L][i]=-1;
    end[L++]=0;
    return L-1;
}
void Insert()
{
    int now=0,len=strlen(s+1),i;
    for(i=1;i<=len;i++)
    {
        if(next[now][s[i]-'a']==-1)
          next[now][s[i]-'a']=newnode();
        now=next[now][s[i]-'a'];
    }
    end[now]++;
}
void build()
{
    queue<int> qu;
    fail[0]=0;
    int i;
    for(i=0;i<26;i++)
       if(next[0][i]==-1)
         next[0][i]=0;
       else
       {
           fail[next[0][i]]=0;
           qu.push(next[0][i]);
       }
    while(!qu.empty())
    {
        int now=qu.front();
        qu.pop();
        for(i=0;i<26;i++)
           if(next[now][i]==-1)
             next[now][i]=next[fail[now]][i];
           else
           {
               fail[next[now][i]]=next[fail[now]][i];
               qu.push(next[now][i]);
           }
    }
}
int query()
{
    int i,now=0,temp,ret=0,len=strlen(s+1);
    for(i=1;i<=len;i++)
    {
        now=next[now][s[i]-'a'];
        temp=now;
        while(temp)
        {
            ret+=end[temp];
            end[temp]=0;
            temp=fail[temp];
        }
    }
    return ret;
}
int main()
{
    int T,t,n,i,j,k,ans;
    scanf("%d",&T);
    for(t=1;t<=T;t++)
    {
        scanf("%d",&n);
        L=0;
        newnode();
        for(i=1;i<=n;i++)
        {
            scanf("%s",s+1);
            Insert();
        }
        build();
        scanf("%s",s+1);
        ans=query();
        printf("%d\n",ans);
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: