您的位置:首页 > 其它

HDU1194_Beat the Spread!

2014-10-29 19:47 381 查看
Beat the Spread!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4683    Accepted Submission(s): 2441

Problem Description

Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two final scores, or on the absolute
difference between the two scores.

Given the winning numbers for each type of bet, can you deduce the final scores?

 

Input

The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final scores.

 

Output

For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing "impossible". Recall that football scores are always non-negative integers.

 

Sample Input

2

40 20

20 40

 

Sample Output

30 10
impossible

题目大意:已知一场比赛两个最终得分的和,以及两个最终得分的绝对值差。

求两个最终得分。若没有这样的两个得分,则输出impossible。最终得分不能

为负

思路:英语理解题。最主要的是读懂题意。两个最种得分的计算方法如下:

a = (s+d)/2,b = (s-d)/2。若a、b都为整数,且都大于0,则满足条件,

否则输出impossible

#include<stdio.h>

int main()
{
int T,s,d;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&s,&d);
int a = -1;
int b = -1;
if((s+d)%2 == 0)
{
a = (s+d)/2;
b = (s-d)/2;
}
if(a>0 && b>0)
printf("%d %d\n",a,b);
else
printf("impossible\n");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: