您的位置:首页 > 其它

HDOJ 题目1073 Online Judge(字符串处理)

2014-10-29 09:58 288 查看


Online Judge

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5380    Accepted Submission(s): 2059


[align=left]Problem Description[/align]
Ignatius is building an Online Judge, now he has worked out all the problems except the Judge System. The system has to read data from correct output file and user's result file, then the system compare the two files. If
the two files are absolutly same, then the Judge System return "Accepted", else if the only differences between the two files are spaces(' '), tabs('\t'), or enters('\n'), the Judge System should return "Presentation Error", else the system will return "Wrong
Answer".

Given the data of correct output file and the data of user's result file, your task is to determine which result the Judge System will return.

 

[align=left]Input[/align]
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case has two parts, the data of correct output file and the data of the user's result file. Both of them are starts with a single line contains a string "START" and end with a single line contains a string "END", these two strings are not the data.
In other words, the data is between the two strings. The data will at most 5000 characters.

 

[align=left]Output[/align]
For each test cases, you should output the the result Judge System should return.

 

[align=left]Sample Input[/align]

4
START
1 + 2 = 3
END
START
1+2=3
END
START
1 + 2 = 3
END
START
1 + 2 = 3

END
START
1 + 2 = 3
END
START
1 + 2 = 4
END
START
1 + 2 = 3
END
START
1 + 2 = 3
END

 

[align=left]Sample Output[/align]

Presentation Error
Presentation Error
Wrong Answer
Presentation Error

 

[align=left]Author[/align]
Ignatius.L
 

[align=left]Recommend[/align]
We have carefully selected several similar problems for you:  1088 1113 1043 1321 1288 
 ac代码
#include<stdio.h>
#include<string.h>
void get(char *s)
{
char temp[5050];
gets(temp);
while(strcmp(temp,"START")!=0)
gets(temp);
while(gets(temp))
{
if(strcmp(temp,"END")==0)
break;
if(strlen(temp)!=0)
{
strcat(s,temp);
}
strcat(s,"\n");
}
}
void fun(char *s,char *temp)
{
int len,i,j=0;
len=strlen(s);
for(i=0;i<len;i++)
{
if(s[i]!=' '&&s[i]!='\t'&&s[i]!='\n')
{
temp[j++]=s[i];
}
}
temp[j]='\0';
//return temp;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
char st[10],en[10],s1[5050],t1[5050],s2[5050],t2[5050];
s1[0]='\0';
s2[0]='\0';
get(s1);
get(s2);
if(strcmp(s1,s2)==0)
{
printf("Accepted\n");
}
else
{
fun(s1,t1);
fun(s2,t2);
if(strcmp(t1,t2)==0)
{
printf("Presentation Error\n");
}
else
printf("Wrong Answer\n");
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: