您的位置:首页 > 其它

USACO 1.3 - Mixing Milk(贪心)

2014-10-27 11:24 204 查看
The Merry Milk Makers company buys milk from farmers, packagesit into attractive 1- and 2-Unit bottles, and then sells that milkto grocery stores so we can each start our day with delicious cerealand milk.

Since milk packaging is such a difficult business in which tomake money, it is important to keep the costs as low as possible.Help Merry Milk Makers purchase the farmers' milk in the cheapestpossible manner. The MMM company has an extraordinarily talentedmarketing
department and knows precisely how much milk they needeach day to package for their customers.

The company has contracts with several farmers from whom theymay purchase milk, and each farmer has a (potentially) differentprice at which they sell milk to the packing plant.Of course, a herd of cows can only produce so much milk eachday, so the farmers
already know how much milk they will haveavailable.

Each day, Merry Milk Makers can purchase an integer number ofunits of milk from each farmer, a number that is always less thanor equal to the farmer's limit (and might be the entire productionfrom that farmer, none of the production, or any integer in between).

Given:

The Merry Milk Makers' daily requirement of milk
The cost per unit for milk from each farmer
The amount of milk available from each farmer

calculate the minimum amount of money that Merry Milk Makers mustspend to meet their daily need for milk.
Note: The total milk produced per day by the farmers will alwaysbe sufficient to meet the demands of the Merry Milk Makers even ifthe prices are high.

PROGRAM NAME: milk

INPUT FORMAT

Line 1:Two integers, N and M.

The first value, N, (0 <= N <=2,000,000) is the amount of milk that Merry Milk Makers wants per day.

The second, M, (0 <= M <= 5,000) is the number of farmersthat they may buy from.
Lines 2 through M+1:The next M lines each containtwo integers: Pi and Ai.

Pi (0 <= Pi <= 1,000) is price incents that farmer i charges.

Ai (0 <= Ai <= 2,000,000) is the amountof milk that farmer i can sell to Merry Milk Makers per day.

SAMPLE INPUT (file milk.in)

100 5
5 20
9 40
3 10
8 80
6 30

INPUT EXPLANATION

100 5 -- MMM wants 100 units of milk from 5 farmers
5 20 -- Farmer 1 says, "I can sell you 20 units at 5 cents per unit"
9 40 etc.
3 10 -- Farmer 3 says, "I can sell you 10 units at 3 cents per unit"
8 80 etc.
6 30 -- Farmer 5 says, "I can sell you 30 units at 6 cents per unit"

OUTPUT FORMAT

A single line with a single integer that is the minimum costthat Merry Milk Makers msut pay for one day's milk.

SAMPLE OUTPUT (file milk.out)

630

OUTPUT EXPLANATION

Here's how the MMM company spent only 630 cents to purchase 100units of milk:
Price

per unit
Units

available
Units

bought
Price *

# units
Total costNotes
520205*20100
9400  Bought no milk from farmer 2
310103*1030
880408*40320Did not buy all 80 units!
630306*30180
Total180100 630Cheapest total cost
                                                                

思路;

1 将价格排序。(我的写法),所谓的傻逼思路。

2. 注意到他的价格两只有 1<= p<=1000,所以完全可以开一个数组p【1005】记录在哪些价格下有商品,这样就无需排序了。

CODE:

/*
ID: sotifis3
LANG: C++
TASK: milk
*/
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int inf = 0xffffff;
struct node
{
int p, m;
double c;
}n[5005];
int K, N;
bool cmp(node x, node y)
{
return x.p < y.p;
}
int main()
{
//freopen("in", "r", stdin);
freopen("milk.in","r",stdin);
freopen("milk.out","w",stdout);
int K, N;
while(~scanf("%d %d", &K, &N)){
if(K == 0){
printf("0\n");
continue;
}
for(int i = 0; i < N; ++i){
scanf("%d %d", &n[i].p, &n[i].m);
//n[i].c = (double) n[i].p / n[i].m;
}
sort(n, n + N, cmp);
long long ans = 0;
for(int i = 0; i < N; i++){
if(K < n[i].m){
printf("%lld\n", n[i].p * K + ans);
break;
}
else{
ans += n[i].m * n[i].p;
n[i].p = inf;
K -= n[i].m;
if(K == 0){
printf("%lld\n", ans);
break;
}
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  USACO 贪心