您的位置:首页 > 其它

poj2342 树形dp

2014-10-27 08:21 274 查看
http://poj.org/problem?id=2342

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make
the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your
task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127.
After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 

L K 

It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 

0 0 

Output

Output should contain the maximal sum of guests' ratings.
Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output
5


/**
poj2342
题目大意:举行party,某人和他的顶头上司不能同时到达,每一个人的到达都会给party带来一定的欢乐值,问邀请哪些人可以使聚会的欢乐值最高。
树形dp。dp[i][0]表示i不去,i和他的子孙节点所带来的最大欢乐值;dp[i][1]表示i去,他和他的子孙节点所带来的最大欢乐值。显然max(dp[root][0],dp[root][1])即为答案。
状态转移方程为:dp[root][1]+=dp[i][0];dp[root][0]+=max(dp[i][0],dp[i][1])(其中i为root的子节点)
采用记忆化搜索的写法更加明了。

**/
#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
int n;
int dp[6050][2],v[6050],vis[6050],father[6050];

void dfs(int root)
{
vis[root]=1;
for(int i=1;i<=n;i++)
{
if(vis[i]==0&&father[i]==root)
{
dfs(i);
dp[root][1]+=dp[i][0];
dp[root][0]+=max(dp[i][0],dp[i][1]);
}
}
}
int main()
{
while(~scanf("%d",&n))
{
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++)
scanf("%d",&dp[i][1]);
memset(father,-1,sizeof(father));
while(1)
{
int k,l;
scanf("%d%d",&l,&k);
if(l==0&&k==0)
break;
father[l]=k;
}
int root;
for(int i=1;i<=n;i++)
if(father[i]==-1)
{
root=i;
break;
}
//cout << root << endl;
memset(vis,0,sizeof(vis));
dfs(root);
printf("%d\n",max(dp[root][1],dp[root][0]));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: