您的位置:首页 > 其它

PAT (Advanced Level) Practise 1016. Phone Bills (25)

2014-10-25 20:12 686 查看


1016. Phone Bills (25)

时间限制

400 ms

内存限制

32000 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone.
Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word "on-line" or "off-line".

For each test case, all dates will be within a single month. Each "on-line" record is paired with the chronologically next record for the same customer provided it is an "off-line" record. Any "on-line" records that are not paired with an "off-line" record
are ignored, as are "off-line" records not paired with an "on-line" record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour
clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning
and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.
Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80


提交代

#include <iostream>
#include <string.h>
#include <algorithm>

using namespace std;

int trans(char a,char b)
{
return (a-48)*10+b-48;
}

int bigger(const char a[30],const char b[30])
{
int i,l;
l=strlen(a)>=strlen(b)?strlen(a):strlen(b);
for(i=0;i<l;i++)
{
if(a[i]>b[i])
return 0;
else if(a[i]<b[i])
return 1;
}
return 2;
}

struct RECORD
{
char name[30];
int month;
int day;
int hour;
int minute;
int onoff;
bool operator <(const RECORD &A) const
{
if(bigger(name,A.name)!=2)
return bigger(name,A.name);
else if(day!=A.day)
return day<A.day;
else if(hour!=A.hour)
return hour<A.hour;
else if(minute!=A.minute)
return minute<A.minute;
else if(onoff!=A.onoff)
return onoff<A.onoff;
}
};

int main()
{
int n,i,j,first,thison,thisoff,findon,findoff,temp,dd,hh,mm;
int price[24];
double total,cost;
char x[30],y[30],z[30],thisname[30];
for(i=0;i<24;i++)
cin>>price[i];
RECORD a[1010];
cin>>n;
for(i=0;i<n;i++)
{
cin>>x>>y>>z;
strcpy(a[i].name,x);
a[i].month=trans(y[0],y[1]);
a[i].day=trans(y[3],y[4]);
a[i].hour=trans(y[6],y[7]);
a[i].minute=trans(y[9],y[10]);
if(z[1]=='n')
a[i].onoff=0;
else a[i].onoff=1;
}
sort(a,a+n);
strcpy(thisname," ");
i=0;
while(i<n)
{
if(strcmp(a[i].name,thisname))
{
if((i!=0)&&(first==1))
printf("Total amount: $%.2lf\n",total/100);
total=0;
first=0;
findon=0;
findoff=0;
strcpy(thisname,a[i].name);
}
if(~findon)
{
if(a[i].onoff==0)
{
findon=1;
thison=i;
}
}
if((findon)&&(~findoff))
{
if(a[i].onoff==1)
{
findoff=1;
thisoff=i;
}
}
if((findon)&&(findoff))
{
findon=0;
findoff=0;
if(first==0)
{
printf("%s %02d\n",a[i].name,a[i].month);
first=1;
}
printf("%02d:%02d:%02d ",a[thison].day,a[thison].hour,a[thison].minute);
printf("%02d:%02d:%02d ",a[thisoff].day,a[thisoff].hour,a[thisoff].minute);
temp=a[thisoff].day*1440+a[thisoff].hour*60+a[thisoff].minute;
temp=temp-(a[thison].day*1440+a[thison].hour*60+a[thison].minute);
printf("%d ",temp);
cost=0;
dd=a[thison].day;
hh=a[thison].hour;
mm=a[thison].minute;
while(1)
{
if(dd>a[thisoff].day)
break;
if((dd==a[thisoff].day)&&(hh>a[thisoff].hour))
break;
if((dd==a[thisoff].day)&&(hh==a[thisoff].hour)&&(mm>a[thisoff].minute-1))
break;
cost=cost+price[hh];
mm++;
if(mm==60)
{
mm=0;
hh++;
}
if(hh==24)
{
hh=0;
dd++;
}
}
printf("$%.2lf\n",cost/100);
total+=cost;
}
i++;
}
if(first==1)
printf("Total amount: $%.2lf\n",total/100);
system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: