您的位置:首页 > 其它

HDU 1003(简单dp)

2014-10-24 23:44 190 查看


Max Sum

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 149579 Accepted Submission(s): 34931



Problem Description

Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence.
If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5


Sample Output

Case 1:
14 1 4

Case 2:
7 1 6


Author

Ignatius.L

题意:求最大子序列和,并输出起始和终点位置。比较简单的dp,用dp[i]来表达,i代表i结尾的和。
做法:dp[i]=max(dp[i-1]+num[i],num[i])。
#include <iostream>
#include <cstdio>
#include <climits>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include <algorithm>
#include<ctime>
#define esp 1e-6
#define LL  long long
#define inf 0x0f0f0f0f
using namespace std;
int main()
{
int t,cas;
int i,j;
int n;
int num[100005];
int dp[100005];
scanf("%d",&t);
for(cas=1;cas<=t;cas++)
{
memset(num,0,sizeof(num));
memset(dp,0,sizeof(dp));
scanf("%d",&n);
for(i=1;i<=n;i++)
scanf("%d",&num[i]);
for(i=1;i<=n;i++)
dp[i]=max(dp[i-1]+num[i],num[i]);
int ans,ll,rr;
ans=-inf;
for(i=1;i<=n;i++)
{
if(dp[i]>ans)
{
ans=dp[i];
rr=i;
}
}
int tt=0;
for(i=rr;i>=1;i--)
{
tt+=num[i];
if(tt==ans)
ll=i;
}
printf("Case %d:\n",cas);
printf("%d %d %d\n",ans,ll,rr);
if(cas!=t)
printf("\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: