您的位置:首页 > 理论基础 > 计算机网络

Power Network (poj 1459 网络流)

2014-10-24 20:44 405 查看
Language:
Default

Power Network

Time Limit: 2000MSMemory Limit: 32768K
Total Submissions: 23407Accepted: 12267
Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= pmax(u) of power, may consume an amount
0 <= c(u) <= min(s(u),cmax(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power
transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= lmax(u,v) of power delivered by u to v. Let Con=Σuc(u) be the power consumed in the net. The problem is to compute the maximum value of
Con.



An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax(u)=y. The label x/y of consumer u shows that c(u)=x and cmax(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and lmax(u,v)=y.
The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6.

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets
(u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of lmax(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of pmax(u). The data set
ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of cmax(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can
occur freely in input. Input data terminate with an end of file and are correct.
Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.
Sample Input
2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output
15
6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second
data set encodes the network from figure 1.
Source

Southeastern Europe 2003
题意:在一个电力网中有n个节点,其中有np个发电站,nc个消耗点,剩下的为中转站,m条电缆。其中只有发电站发电,每个发电站所能发电的最大值已知,只有消耗点消耗电,每个消耗点消耗的最大值已知。中转站即不消耗也不发电。每条电缆都有个传送电力的限制。为该网络所能消耗的最大电力。

思路:设一个源s和一个汇t,最后把源s和发电厂连接,边的容量为发电厂的容量,将用户与汇t连接,容量为用户的容量。

这是我做的第一个网络流,今天 看了一天,终于懂了一点。

代码:

//最短增广路算法(SAP)
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 1005
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

int d[maxn];
int mp[maxn][maxn];
int num[maxn];
int pre[maxn];
int n,m,s,t,np,nc;

void init()
{
    int k;
    queue<int>Q;
    memset(d,INF,sizeof(d));
    memset(num,0,sizeof(num));
    d[t]=0;
    num[0]=1;
    Q.push(t);
    while (!Q.empty())
    {
        k=Q.front();
        Q.pop();
        for (int i=0;i<n;i++)
        {
            if (d[i]>=n&&mp[i][k]>0)
            {
                d[i]=d[k]+1;
                Q.push(i);
                num[d[i]]++;
            }
        }
    }
}

int findAlowFlow(int i)
{
    int j;
    for (j=0;j<n;j++)
        if (mp[i][j]>0&&d[i]==d[j]+1)
            return j;
    return -1;
}

int reLable(int i)
{
    int mm=INF;
    for (int j=0;j<n;j++)
        if (mp[i][j]>0)
            mm=min(mm,d[j]+1);
    return mm==INF?n:mm;
}

int maxFlow(int s,int t)
{
    int flow=0,i=s,j;
    int delta;
    memset(pre,-1,sizeof(pre));
    while (d[s]<n)
    {
        j=findAlowFlow(i);
        if (j>=0)
        {
            pre[j]=i;
            i=j;
            if (i==t)
            {
                delta=INF;
                for (i=t;i!=s;i=pre[i])
                    delta=min(delta,mp[pre[i]][i]);
                for (i=t;i!=s;i=pre[i])
                    mp[pre[i]][i]-=delta,mp[i][pre[i]]+=delta;
                flow+=delta;
            }
        }
        else
        {
            int x=reLable(i);
            num[x]++;
            num[d[i]]--;
            if (num[d[i]]==0)
                return flow;
            d[i]=x;
            if (i!=s)
                i=pre[i];
        }
    }
    return flow;
}

int main()
{
    while (scanf("%d%d%d%d",&n,&np,&nc,&m)!=EOF)
    {
        int u,v,w;
        memset(mp,0,sizeof(mp));
        for (int i=0;i<m;i++)
        {
            scanf(" (%d,%d)%d",&u,&v,&w);
            mp[u][v]=w;
        }
        for (int i=0;i<np;i++)
        {
            scanf(" (%d)%d",&u,&w);
            mp
[u]=w;
        }
        for (int i=0;i<nc;i++)
        {
            scanf(" (%d)%d",&u,&w);
            mp[u][n+1]=w;
        }
        s=n;
        t=n+1;
        n=n+2;
//        printf("n=%d\n",n);
        init();
        printf("%d\n",maxFlow(s,t));
    }
    return 0;
}


一般增广路算法(EK)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 1005
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

bool used[maxn];
int pre[maxn];
int mp[maxn][maxn];
int n,np,nc,m;

int ford()
{
    int i,res=0,now,mi;
    queue<int>Q;
    while (1)
    {
        memset(pre,-1,sizeof(pre));
        memset(used,0,sizeof(used));
        while (!Q.empty())
            Q.pop();
        Q.push(0);
        used[0]=true;
        while (!Q.empty())
        {
            now=Q.front();
            Q.pop();
            if (now==n)
                break;
            for (i=0;i<=n;i++)
            {
                if (!used[i]&&mp[now][i]>0)
                {
                    pre[i]=now;
                    used[i]=true;
                    Q.push(i);
                }
            }
        }
        if (!used
)
            break;
        mi=INF;
        for (i=n;i!=0;i=pre[i])
            if (mp[pre[i]][i]<mi)
                mi=mp[pre[i]][i];
        res+=mi;
        for (i=n;i!=0;i=pre[i])
        {
            mp[pre[i]][i]-=mi;
            mp[i][pre[i]]+=mi;
        }
    }
    return res;
}

int main()
{
    while (scanf("%d%d%d%d",&n,&np,&nc,&m)!=EOF)
    {
        int u,v,w;
        memset(mp,0,sizeof(mp));
        for (int i=0;i<m;i++)
        {
            scanf(" (%d,%d)%d",&u,&v,&w);
            mp[u+1][v+1]=w;
        }
        for (int i=0;i<np;i++)
        {
            scanf(" (%d)%d",&u,&w);
            mp[0][u+1]=w;
        }
        for (int i=0;i<nc;i++)
        {
            scanf(" (%d)%d",&u,&w);
            mp[u+1][n+1]=w;
        }
        n=n+1;
//        printf("n=%d\n",n);
        printf("%d\n",ford());
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: