您的位置:首页 > 其它

pat 1004 Counting Leaves

2014-10-24 09:57 323 查看
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members
who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children,
followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end
of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.
Sample Input
2 1
01 1 02

Sample Output
0 1


#include <stdio.h>
#include <stdlib.h>

//using namespace std;

int main()
{
//freopen("F:/CppProject/data/1004.txt","r",stdin);
int n,m,height=1;
int haschild[100]={0},level[100]={0},result[100]={0};//haschild=1表示该节点不是叶子节点,level每个节点所在层数,根节点为1层,result表示每层的叶子数。
int pre[100]={0};
scanf("%d%d",&n,&m);
level[1]=1;
int current,k;
for(int i=0;i<m;i++)
{
scanf("%d%d",¤t,&k);
if(k>0)
haschild[current]=1;
for(int i=0;i<k;i++)
{
int tmp=0;
scanf("%d",&tmp);
pre[tmp]=current;
//level[tmp]=level[current]+1;
//height=height>level[tmp]?height:level[tmp];
}
}
for(int i=1;i<=n;i++)
{
level[i]=level[pre[i]]+1;
height=height>level[i]?height:level[i];
}
for(int i=1;i<=n;i++)
{
if(!haschild[i])
{
result[level[i]]++;
}
//printf("%d##",level[i]);
}
for(int i=1;i<height;i++)
{
printf("%d ",result[i]);
}
printf("%d",result[height]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat 1004