您的位置:首页 > 其它

pat 1002 A+B for Polynomials

2014-10-24 09:54 369 查看
This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where
K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output
3 2 1.5 1 2.9 0 3.2

#include <stdio.h>
#include <stdlib.h>
using namespace std;

int main()
{
//freopen("F:/CppProject/data/1002.txt","r",stdin);
double result[1002]={0.0},first[1002]={0.0},sec[1002]={0.0};
int n,exp,max=0,min=0;
double tmp;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d%lf",&exp,&tmp);
max=exp>max?exp:max;
first[exp]=tmp;
}
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d%lf",&exp,&tmp);
max=exp>max?exp:max;
sec[exp]=tmp;
}

int total=0,f=0;
for(int i=0;i<=max;i++)
{
result[i]=first[i]+sec[i];
if(result[i]!=0)
{
total++;
if(f==0)
{
min=i;
f=1;
}
}
}
printf("%d",total);
while(max>=min)
{
if(result[max]!=0)
{
printf(" %d %.1lf",max,result[max]);

}
max--;
}
//if(result[min]!=0)
//printf("%d %.1f\n",min,result[min]);
printf("\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat 1002