您的位置:首页 > 产品设计 > UI/UE

[HDU 1806] Frequent values

2014-10-23 14:12 288 查看

Frequent values

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1146 Accepted Submission(s): 415


[align=left]Problem Description[/align]
You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , ... , aj .

[align=left]Input[/align]
The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains n integers a1 , ... , an(-100000 ≤ ai ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the query.

The last test case is followed by a line containing a single 0.

[align=left]Output[/align]
For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

[align=left]Sample Input[/align]

10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0

[align=left]Sample Output[/align]

1
4
3

Hint

A naive algorithm may not run in time!

分成三段、中间RMQ、然后求最大值即可

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
#define N 100010

int n,m;
int a
;
int dp
[20];
int id
;
int len
,l
,r
;

void init()
{
int i,j;
for(i=1;i<=n;i++)
{
dp[i][0]=len[i];
}
int k=(int)(log((double)n)/log(2.0));
for(j=1;j<=k;j++)
{
for(i=1;i+(1<<j)-1<=n;i++)
{
dp[i][j]=max(dp[i][j-1],dp[i+(1<<(j-1))][j-1]);
}
}
}
int query(int i,int j)
{
int k=(int)(log((double)(j-i+1))/log(2.0));
int res=max(dp[i][k],dp[j-(1<<k)+1][k]);
return res;
}
int main()
{
int i,pos;
while(scanf("%d",&n),n)
{
pos=0;
scanf("%d",&m);
for(i=1;i<=n;i++)
{
scanf("%d",&a[i]);
if(a[i]!=a[i-1])
{
pos++;
l[pos]=i;
}
id[i]=pos;
r[pos]=i;
len[pos]=r[pos]-l[pos]+1;
}
n=pos;
init();
int x,y,xx,yy,ans1,ans2,ans3;
while(m--)
{
int x,y;
scanf("%d%d",&x,&y);
xx=id[x];
yy=id[y];
if(xx==yy) ans1=ans2=y-x+1; //特殊情况、当x和y在同一个区间、答案是y-x+1
else
{
ans1=r[xx]-x+1;
ans2=y-l[yy]+1;
}
ans3=0;
if(xx+1<=yy-1)ans3=query(xx+1,yy-1);
printf("%d\n",max(max(ans1,ans2),ans3));
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: