您的位置:首页 > 其它

HDOJ 题目1217 Arbitrage(最短路径,Floyd)

2014-10-23 00:30 281 查看
NEW~ 关于举办计算机学院大学生程序设计竞赛(2014'11)的报名通知

Arbitrage

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4737    Accepted Submission(s): 2162


Problem Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French
franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

 

Input

The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear.
The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency.
Exchanges which do not appear in the table are impossible.

Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n. 

 

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No". 

 

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

 

Sample Output

Case 1: Yes
Case 2: No

 

Source

University of Ulm Local Contest 1996
 

Recommend

Eddy   |   We have carefully selected several similar problems for you:  1142 1385 1301 1596 2112 
 
Dijkstra算法不能处理带有负权值的最短路,但此题中,两种货币之间的兑换比率可能小于1

ac代码
#include<stdio.h>
#include<string.h>
#include<string>
#include<map>
#include<iostream>
using namespace std;
int n,m;
double ma[50][50],rate;
void init()
{
int i,j;
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
ma[i][j]=0;
ma[i][i]=1;
}
}
void floyd()
{
int i,j,k;
for(k=1;k<=n;k++)
{
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
if(ma[i][j]<ma[i][k]*ma[k][j])
{
ma[i][j]=ma[i][k]*ma[k][j];
}
}
}
}
int main()
{
char s[100],s1[100],s2[100];
int c=0;
while(scanf("%d",&n)!=EOF,n)
{
int i,j,k,w=1;
map<string,int>mm;
for(i=1;i<=n;i++)
{
scanf("%s",s);
mm[s]=i;
}
scanf("%d",&m);
init();
for(i=0;i<m;i++)
{
int a,b;
scanf("%s%lf%s",s1,&rate,s2);
a=mm[s1];
b=mm[s2];
ma[a][b]=rate;
}
floyd();
for(i=1;i<=n;i++)
if(ma[i][i]>1)
{
w=0;
break;
}
printf("Case %d: ",++c);
if(w==0)
printf("Yes\n");
else
printf("No\n");
}
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: