您的位置:首页 > 其它

Wormholes(最短路_bellman_ford)

2014-10-22 14:13 351 查看
Wormholes

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 31762Accepted: 11561
Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms
comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N,
M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to
F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.

Line 1 of each farm: Three space-separated integers respectively: N,
M, and W

Lines 2..M+1 of each farm: Three space-separated numbers (S,
E, T) that describe, respectively: a bidirectional path between
S and E that requires T seconds to traverse. Two fields might be connected by more than one path.

Lines M+2..M+W+1 of each farm: Three space-separated numbers (S,
E, T) that describe, respectively: A one way path from S to
E that also moves the traveler back T seconds.
Output
Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output
NO

YESHintFor farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
题意:John的农场里N块地,M条路连接两块地,W个虫洞,虫洞是一条单向路,会在你离开之前把你传送到目的地,就是当你过去的时候时间会倒退Ts。我们的任务是知道会不会在从某块地出发后又回来,看到了离开之前的自己。思路:其实就是看看有没有负环,如果有负环的话就证明能回去就输出YES,没有就输出NO。可以用贝尔曼福德判断一下负环

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
#define inf 0x3f3f3f3f
struct node
{
int u,v,w;
} edge[6010];
int dis[510];
int cnt;
int n,m,W;
void add_edge(int u,int v,int w)
{
edge[cnt].u=u;
edge[cnt].v=v;
edge[cnt].w=w;
cnt++;
}
int bellman_ford()
{
int i,j;
for(i=1; i<=n; i++)
dis[i]=inf;
dis[1]=0;
for(i=1; i<n; i++)
{
int flag=0;
for(j=0; j<cnt; j++)
{
if(dis[edge[j].v]>dis[edge[j].u]+edge[j].w)
{
dis[edge[j].v]=dis[edge[j].u]+edge[j].w;
flag=1;
}
}
if(!flag)
break;
}
for(i=0; i<cnt; i++)
if(dis[edge[i].v]>dis[edge[i].u]+edge[i].w)
return 1;
return 0;

}
int main()
{
int T;
int u,v,w;
scanf("%d",&T);
while(T--)
{
cnt=0;
scanf("%d %d %d",&n,&m,&W);
while(m--)
{
scanf("%d %d %d",&u,&v,&w);
add_edge(u,v,w);
add_edge(v,u,w);
}
while(W--)
{
scanf("%d %d %d",&u,&v,&w);
add_edge(u,v,-w);
}
if(bellman_ford())
printf("YES\n");
else
printf("NO\n");
}
return 0;
}



内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: