您的位置:首页 > 其它

HDU1098 Ignatius's puzzle 【数论】

2014-10-22 07:10 513 查看

Ignatius's puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6559    Accepted Submission(s): 4540

[align=left]Problem Description[/align]
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer
a,make the arbitrary integer x ,65|f(x)if

no exists that a,then print "no".

 

[align=left]Input[/align]
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.

 

[align=left]Output[/align]
The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.

 

[align=left]Sample Input[/align]

11
100
9999

 

[align=left]Sample Output[/align]

22
no
43

 

[align=left]Author[/align]
eddy

题意:求出使x为任意值时f(x)都能被65整除的最小a的值,若不存在输出no。

题解:若任意f(x)都能被65整除,那么f(1)%65==0,(f(x+1)-f(x))%65 == 0,二项式展开得(18+k*a)%65 == 0,所以只需要遍历找到a即可。

#include <stdio.h>

int main() {
int k, a;
while(~scanf("%d", &k)) {
for(a = 0; a <= 65; ++a)
if((18 + k*a) % 65 == 0) {
printf("%d\n", a);
break;
}
if(a > 65) printf("no\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU1098