您的位置:首页 > 其它

HDU 3336 Count the string(kmp)

2014-10-21 21:12 453 查看
Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:

s: "abab"

The prefixes are: "a", "ab", "aba", "abab"

For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab",
it is 2 + 2 + 1 + 1 = 6.

The answer may be very large, so output the answer mod 10007.



Input
The first line is a single integer T, indicating the number of test cases.

For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.



Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.


Sample Input
1
4
abab




Sample Output
6




Author
foreverlin@HNU


Source
HDOJ Monthly Contest – 2010.03.06



我看完别人博客后发现了kmp的一个秘密,就是当nexti[i]!=0(i从1开始),那么就会有一个串就是母串从头开始的一部分,至于为什么自己把nexti]数组输出一下吧

代码还是kmp模板:

</pre><pre name="code" class="cpp">#include<iostream>
#include<cmath>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<algorithm>
#include<vector>
#include<map>
#include<stack>
#include<list>
#include<queue>
#define eps 1e-6
#define INF (1<<30)
#define PI acos(-1.0)
using namespace std;

#define N 220000
#define mod 10007

int n,next
;
char a
;

void getfail(char *a)
{
   int i,j;
   int len=strlen(a);
   j=-1;
   i=0;
   next[0]=-1;
   while(i<len)
   {
      if(j==-1||a[i]==a[j])
      {
         i++;
         j++;
         next[i]=j;
      }
      else
         j=next[j];
   }
}

int main()
{
   int i,j,t;
   scanf("%d",&t);
   while(t--)
   {
     scanf("%d",&j);
     scanf("%s",a);
     getfail(a);

     int len=strlen(a);
     int ans=0;
     for(i=1;i<=len;i++)
         if(next[i])
     {
        ans++;
        ans%=mod;
     }
   ans=(ans+len)%mod;
   printf("%d\n",ans);
   }
   return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: