您的位置:首页 > 其它

Leftmost Digit

2014-10-20 20:51 127 查看


Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 13438    Accepted Submission(s): 5159


Problem Description

Given a positive integer N, you should output the leftmost digit of N^N.

 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

 

Output

For each test case, you should output the leftmost digit of N^N.

此题充分利用log来解题,n^n=x -> nlgn=lgx x=10^(nlgn)  ->由此易有nlgn又小数部分和整数部分组成,及可以通过数值的转化来求题,考虑到此题数字较大,我们使用_int64和double来得到小数部分来解题,及通过10^小数得到最高位。

 

Sample Input

2
3
4

 

Sample Output

2
2

Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.

#include <stdio.h>
#include <math.h>
int main()
{
int i;
int Case;
double num;
int  result;
double reminder;
double temp;
scanf("%d",&Case);
while(Case--)
{
scanf("%lf",&num);
temp=num*log10(num);
reminder=temp-(__int64)(temp);
result=pow(10,reminder);
printf("%d\n",result);
}
return 0;
此题充分利用log来解题,n^n=x -> nlgn=lgx x=10^(nlgn)  ->由此易有nlgn又小数部分和整数部分组成,及可以通过数值的转化来求题,考虑到此题数字较大,我们使用_int64和double来得到小数部分来解题,及通过10^小数得到最高位。

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: