您的位置:首页 > 其它

lightoj1045 - Digits of Factorial

2014-10-20 19:58 453 查看

Digits of Factorial

[align=center]Time Limit: 2000MS Memory Limit: 32768KByte 64 IO Format:%lld & %llu[/align]

Description

Factorial of an integer is defined by the following function

f(0) = 1

f(n) = f(n - 1) * n, if(n > 0)

So, factorial of 5 is 120. But in different bases, the factorial may be different. For example, factorial of 5 in base 8 is 170.

In this problem, you have to find the number of digit(s) of the factorial of an integer in a certain base.

Input

Input starts with an integer T (≤ 50000), denoting the number of test cases.

Each case begins with two integers n (0 ≤ n ≤ 106) and base (2 ≤ base ≤ 1000). Both of these integers will be given in decimal.

Output

For each case of input you have to print the case number and the digit(s) of factorial n in the given base.

Sample Input

5

5 10

8 10

22 3

1000000 2

0 100

Sample Output

Case 1: 3

Case 2: 5

Case 3: 45

Case 4: 18488885

Case 5: 1

#include<stdio.h>
#include<math.h>
double ans, f[1000000] = {0};
void getdigit()
{
for(int i = 1; i <= 1000000; i++)
f[i] = f[i-1] + log(i);//表示  log(1 )+log(2)+。。。+log(i)
}
int main()
{
int i, j, n, base, t, cas;
scanf("%d", &t);
getdigit();
for(cas = 1; cas <= t; cas++)
{
scanf("%d%d",&n, &base);
if(n == 0)
printf("Case %d: 1\n", cas);//0在任何的进制里都是0, 故个数就是0
else
{
ans = f
/ log(base) + 1;//用到了换底公式
printf("Case %d: %d\n",cas, (int)ans);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: