您的位置:首页 > 其它

USACO 1.1 - Friday the Thirteenth(STL: map)

2014-10-20 18:05 316 查看
Is Friday the 13th really an unusual event?

That is, does the 13th of the month land on a Friday less often thanon any other day of the week? To answer this question, write a programthat will compute the frequency that the 13th of each month lands onSunday, Monday, Tuesday, Wednesday, Thursday, Friday,
and Saturday overa given period of N years. The time period to test will be from January1, 1900 to December 31, 1900+N-1 for a given number of years, N. N ispositive and will not exceed 400.

Note that the start year is NINETEEN HUNDRED, not 1990.

There are few facts you need to know before you can solve this problem:

January 1, 1900 was on a Monday.
Thirty days has September, April, June, and November, all the resthave 31 except for February which has 28 except in leap years when ithas 29.
Every year evenly divisible by 4 is a leap year (1992 = 4*498 so1992 will be a leap year, but the year 1990 is not a leap year)
The rule above does not hold for century years. Century yearsdivisible by 400 are leap years, all other are not. Thus, the centuryyears 1700, 1800, 1900 and 2100 are not leap years, but 2000 is a leapyear.
Do not use any built-in date functions in your computer language.

Don't just precompute the answers, either, please.

PROGRAM NAME: friday

INPUT FORMAT

One line with the integer N.

SAMPLE INPUT (file friday.in)

20

OUTPUT FORMAT

Seven space separated integers on one line. These integers representthe number of times the 13th falls on Saturday, Sunday, Monday,Tuesday, ..., Friday.

SAMPLE OUTPUT (file friday.out)

36 33 34 33 35 35 34


                                                        

map 的使用

CODE:

/*
ID:sotifis3
LANG:C++
TASK:friday
*/
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <string>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#include <set>
#include <map>
const int inf=0xfffffff;
typedef long long ll;
using namespace std;

int ans[10];
int m[] = {0, 31, 29, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};

bool is_rui(int y)
{
if(y % 100 == 0){
if(y % 400 == 0) return true;
else return false;
}
else{
if(y % 4 == 0) return true;
else return false;
}
}
int main()
{
freopen("friday.in","r",stdin);
freopen("friday.out","w",stdout);
int n;
scanf("%d", &n);
int s = 13;
for(int i = 1900; i < 1900 + n; ++i){
if(is_rui(i)) m[2] = 29;
else m[2] = 28;
for(int j = 1; j <= 12; ++j){
ans[s % 7] ++;
s += m[j];
}
}
printf("%d %d %d %d %d %d %d\n", ans[6], ans[0], ans[1], ans[2], ans[3], ans[4], ans[5]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  USACO STL