您的位置:首页 > 其它

UVA - 1352

2014-10-20 17:01 316 查看
Colored Cubes

Time Limit: 3000MSMemory Limit: Unknown64bit IO Format: %lld & %llu
Submit Status

Description





There are several colored cubes. All of them are of the same size but they may be colored differently. Each face of these cubes has a single color. Colors of distinct faces of a cube may or may not be the same.
Two cubes are said to be identically colored if some suitable rotations of one of the cubes give identical looks to both of the cubes. For example, two cubes shown in Figure 2 are
identically colored. A set of cubes is said to be identically colored if every pair of them are identically colored.
A cube and its mirror image are not necessarily identically colored. For example, two cubes shown in Figure 3 are not identically colored.
You can make a given set of cubes identically colored by repainting some of the faces, whatever colors the faces may have. In Figure 4, repainting four faces makes the three cubes identically colored and repainting
fewer faces will never do.
Your task is to write a program to calculate the minimum number of faces that needs to be repainted for a given set of cubes to become identically colored.

Input

The input is a sequence of datasets. A dataset consists of a header and a body appearing in this order. A header is a line containing one positive integer n and the body following
it consists of n lines. You can assume that 1

n

4 .
Each line in a body contains six color names separated by a space. A color name consists of a word or words connected with a hyphen (-). A word consists of one or more lowercase letters. You can assume that a color name is at most 24-characters long including
hyphens.
A dataset corresponds to a set of colored cubes. The integer n corresponds to the number of cubes. Each line of the body corresponds to a cube and describes the colors of its
faces. Color names in a line is ordered in accordance with the numbering of faces shown in Figure 5. A line

color1 color2 color3 color4 color5 color6

corresponds to a cube colored as shown in Figure 6.
The end of the input is indicated by a line containing a single zero. It is not a dataset nor a part of a dataset.



[align=CENTER]Figure 2: Identically colored cubes[/align]



[align=CENTER]Figure 3: cubes that are not identically colored[/align]



[align=CENTER]Figure 4: An example of recoloring[/align]



[align=CENTER]Figure 5: Numbering of faces Figure 6: Coloring[/align]

Output

For each dataset, output a line containing the minimum number of faces that need to be repainted to make the set of cub es identically colored.

Sample Input

3
scarlet green blue yellow magenta cyan
blue pink green magenta cyan lemon
purple red blue yellow cyan green
2
red green blue yellow magenta cyan
cyan green blue yellow magenta red
2
red green gray gray magenta cyan
cyan green gray gray magenta red
2
red green blue yellow magenta cyan
magenta red blue yellow cyan green
3
red green blue yellow magenta cyan
cyan green blue yellow magenta red
magenta red blue yellow cyan green
3
blue green green green green blue
green blue blue green green green
green green green green green sea-green
3
red yellow red yellow red yellow
red red yellow yellow red yellow
red red red red red red
4
violet violet salmon salmon salmon salmon
violet salmon salmon salmon salmon violet
violet violet salmon salmon violet violet
violet violet violet violet salmon salmon
1
red green blue yellow magenta cyan
4
magenta pink red scarlet vermilion wine-red
aquamarine blue cyan indigo sky-blue turquoise-blue
blond cream chrome-yellow lemon olive yellow
chrome-green emerald-green green olive vilidian sky-blue
0


Sample Output

4
2
0
0
2
3
4
4
0
16


题意:n个带颜色的立方体,每个面都有一种颜色。要求重新涂尽量少的面,使得所有立方体完全相同。立方体可以旋转。
做法:看了白书的讲解,就是每个立方体可以旋转出24种姿势,然后一个立方体不动,其他立方体各自枚举24种姿势,把最小值记录即可。
#include <iostream>
#include <cstdio>
#include <climits>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <algorithm>
#include<ctime>
#define esp 1e-6
#define LL  long long
#define inf 0x0f0f0f0f
#define maxn 4
using namespace std;
const int dice24[24][6] = {
{2, 1, 5, 0, 4, 3}, {2, 0, 1, 4, 5, 3}, {2, 4, 0, 5, 1, 3}, {2, 5, 4, 1, 0, 3},
{4, 2, 5, 0, 3, 1}, {5, 2, 1, 4, 3, 0}, {1, 2, 0, 5, 3, 4}, {0, 2, 4, 1, 3, 5},
{0, 1, 2, 3, 4, 5}, {4, 0, 2, 3, 5, 1}, {5, 4, 2, 3, 1, 0}, {1, 5, 2, 3, 0, 4},
{5, 1, 3, 2, 4, 0}, {1, 0, 3, 2, 5, 4}, {0, 4, 3, 2, 1, 5}, {4, 5, 3, 2, 0, 1},
{1, 3, 5, 0, 2, 4}, {0, 3, 1, 4, 2, 5}, {4, 3, 0, 5, 2, 1}, {5, 3, 4, 1, 2, 0},
{3, 4, 5, 0, 1, 2}, {3, 5, 1, 4, 0, 2}, {3, 1, 0, 5, 4, 2}, {3, 0, 4, 1, 5, 2},
};
int n,dice[maxn][6],ans;
vector<string>names;
int id(char *name)
{
string s(name);
int n=names.size();
for(int i=0;i<n;i++)
if(s==names[i]) return i;
names.push_back(s);
return n;
}
int r[maxn],color[maxn][6];
void check()
{
for(int i=0;i<n;i++)
for(int j=0;j<6;j++)
color[i][dice24[r[i]][j]]=dice[i][j];
int tot=0;
for(int j=0;j<6;j++)
{
int cnt[maxn*6];
memset(cnt,0,sizeof(cnt));
int max1=0;
for(int i=0;i<n;i++)
{
max1=max(max1,++cnt[color[i][j]]);
}
tot+=n-max1;
}
ans=min(ans,tot);
}
void dfs(int d)
{
if(d==n)
check();
else
{
for(int i=0;i<24;i++)
{
r[d]=i;
dfs(d+1);
}
}
}
int main()
{
while(scanf("%d",&n)!=EOF)
{
if(n==0)
break;
names.clear();
for(int i=0;i<n;i++)
for(int j=0;j<6;j++)
{
char ss[30];
scanf("%s",ss);
dice[i][j]=id(ss);
}
ans=n*6;
r[0]=0;
dfs(1);
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: