您的位置:首页 > 其它

poj2356 Find a multiple(鸽巢原理)

2014-10-20 16:53 423 查看
Find a multiple

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6172 Accepted: 2689 Special Judge
Description

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of
given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).
Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.
Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate
line each) in arbitrary order. 

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.
Sample Input
5
1
2
3
4
1

Sample Output
2
2
3

Source

Ural Collegiate Programming Contest 1999

鸽巢原理好强大。。
题意:给你n个数,要从中选出一些数来使他们的和为n的倍数
解题思路:
先证题目一定有解,设一段长为n的数的前缀和为a1,a2,.....,an,这n个数若有一个n的倍数,那么就是答案,否则,在剩下的n-1个余数中这n个一定有两个同余,那么他们差也一定是n的倍数。所以维护前缀和即可。

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int sum,n,l,r;
int p[10010],x[10010];
void work(){
sum=0;
memset(p,-1,sizeof p);
p[0]=0;
for(int i=1;i<=n;i++){
scanf("%d",&x[i]);
sum=(sum+x[i])%n;
if(p[sum]!=-1){
l=p[sum];
r=i;
}else{
p[sum]=i;
}
}
printf("%d\n",r-l);
for(int i=l+1;i<=r;i++) printf("%d\n",x[i]);
}
int main(){
while(~scanf("%d",&n)){
work();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: