您的位置:首页 > 其它

HDU 1867 KMP

2014-10-19 10:05 267 查看
第一次写的时候是直接使用next数组的,思路应该是对的,但是一直是数组越界。。。。。。

所以换了种思路,直接用KMP,(可以多试几个案例。。。)

A + B for you again

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4490 Accepted Submission(s): 1155



[align=left]Problem Description[/align]
Generally speaking, there are a lot of problems about strings processing. Now you encounter another such problem. If you get two strings, such as “asdf” and “sdfg”, the result of the addition between them is “asdfg”, for “sdf” is
the tail substring of “asdf” and the head substring of the “sdfg” . However, the result comes as “asdfghjk”, when you have to add “asdf” and “ghjk” and guarantee the shortest string first, then the minimum lexicographic second, the same rules for other additions.

[align=left]Input[/align]
For each case, there are two strings (the chars selected just form ‘a’ to ‘z’) for you, and each length of theirs won’t exceed 10^5 and won’t be empty.

[align=left]Output[/align]
Print the ultimate string by the book.

[align=left]Sample Input[/align]

asdf sdfg
asdf ghjk


[align=left]Sample Output[/align]

asdfg
asdfghjk


#include <stdio.h>
#include <stdlib.h>
#include <limits.h>
#include <ctype.h>
#include <malloc.h>
#include <string.h>
#include <string>
#include <algorithm>
#include <iostream>
#include <deque>
#include <vector>
#include <set>
#include <map>
using namespace std;
#define MAXN 100000 + 100
char a[MAXN],b[MAXN];
int next1[MAXN],next2[MAXN];

void Getnext(char a[],int next[]){
int i = 0;
int j = -1;
next[0] = -1;
int len = strlen(a);
while(i < len){
if(j==-1 || a[i]==a[j]){
i++;
j++;
next[i] = j;
}
else{
j = next[j];
}
}
}

int KMP(char a[],char b[],int next[]){
int i=0,j=0;
int len1 = strlen(a);
int len2 = strlen(b);
while(i < len1){
if(j==-1 || a[i]==b[j]){
i++;
j++;
}
else{
j = next[j];
}
}

return j;
}

int main(){
int i;

while(~scanf("%s",a)){
scanf("%s",b);
memset(next1,0,sizeof(next1));
memset(next2,0,sizeof(next2));
Getnext(a,next1);
Getnext(b,next2);
int len1 = strlen(a);
int len2 = strlen(b);
int s1 = KMP(a,b,next2);
int s2 = KMP(b,a,next1);
//printf("%d %d\n",s1,s2);
if(s1 == s2){
if(strcmp(a,b)<0){
printf("%s%s\n",a,b+s1);
}
else{
printf("%s%s\n",b,a+s1);
}
}
//printf("%d %d\n",s1,s2);
else if(s1 > s2){
printf("%s%s\n",a,b+s1);
}
else{
printf("%s%s\n",b,a+s2);
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: