您的位置:首页 > 其它

HDOJ 题目2669 Romantic(拓展的欧几里得,模板)

2014-10-18 22:41 387 查看


Romantic

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3149    Accepted Submission(s): 1243


Problem Description

The Sky is Sprite.

The Birds is Fly in the Sky.

The Wind is Wonderful.

Blew Throw the Trees

Trees are Shaking, Leaves are Falling.

Lovers Walk passing, and so are You. 

................................Write in English class by yifenfei


 

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!

Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.

 

Input

The input contains multiple test cases.

Each case two nonnegative integer a,b (0<a, b<=2^31)

 

Output

output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. 

 

Sample Input

77 51
10 44
34 79

 

Sample Output

2 -3
sorry
7 -3

 

Author

yifenfei

 

Source

HDU女生专场公开赛——谁说女子不如男

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  2668 2671 2670 2672 2673 

 
ac代码
#include<stdio.h>
#include<string.h>
__int64 exgcd(__int64 a,__int64 b,__int64 &x,__int64 &y)
{
if(b==0)
{
x=1;
y=0;
return a;
}
else
{
__int64 d=exgcd(b,a%b,x,y);
__int64 t=x;
x=y;
y=t-a/b*y;
return d;
}
}
int main()
{
__int64 a,b,x,y;
while(scanf("%I64d%I64d",&a,&b)!=EOF)
{
__int64 d=exgcd(a,b,x,y);
if(1%d)
printf("sorry\n");
else
{
while(x<0)
{
x+=b;
y-=a;
}
printf("%I64d %I64d\n",x,y);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: