您的位置:首页 > 其它

hdu 2122 Ice_cream’s world III(最小生成树)

2014-10-18 20:02 513 查看
[align=left]Problem Description[/align]
ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every
city to the capital. The project’s cost should be as less as better.

[align=left]Input[/align]
Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.

[align=left]Output[/align]
If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.

[align=left]Sample Input[/align]

2 1
0 1 10

4 0


[align=left]Sample Output[/align]

10

impossible


最小生成树

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
const int MAX=1005;
int father[MAX];
struct node
{
int u;
int v;
int w;

bool operator<(const node &t)const
{
return w<t.w;
}
}e[MAX*10];
int Find(int x)
{
if(x!=father[x])
{
father[x]=Find(father[x]);
}
return father[x];
}
void Union(int x,int y)
{
x=Find(x);
y=Find(y);
if(x!=y)
{
father[x]=y;
}
}

int main()
{
int n,m;
while(scanf("%d%d",&n,&m)!=EOF)
{

int i;
for(i=0;i<=n;i++)
{
father[i]=i;
}
for(i=0;i<m;i++)
{
scanf("%d%d%d",&e[i].u,&e[i].v,&e[i].w);
}
sort(e,e+m);

int sum=0;
int ans=0;
for(i=0;i<m;i++)
{
if(Find(e[i].u)!=Find(e[i].v))
{
ans++;
Union(e[i].u,e[i].v);
sum+=e[i].w;
}
}
if(ans!=n-1)
{
printf("impossible\n");
}
else
{
printf("%d\n",sum);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: