您的位置:首页 > 其它

HDoj-1079 || Poj-1082-Calendar Game

2014-10-18 11:25 316 查看

Calendar Game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2726    Accepted Submission(s): 1575


[align=left]Problem Description[/align]
Adam and Eve enter this year’s ACM International Collegiate Programming Contest. Last night, they played the Calendar Game, in celebration of this contest. This game consists of the dates from January 1, 1900 to November 4, 2001,
the contest day. The game starts by randomly choosing a date from this interval. Then, the players, Adam and Eve, make moves in their turn with Adam moving first: Adam, Eve, Adam, Eve, etc. There is only one rule for moves and it is simple: from a current
date, a player in his/her turn can move either to the next calendar date or the same day of the next month. When the next month does not have the same day, the player moves only to the next calendar date. For example, from December 19, 1924, you can move either
to December 20, 1924, the next calendar date, or January 19, 1925, the same day of the next month. From January 31 2001, however, you can move only to February 1, 2001, because February 31, 2001 is invalid.

A player wins the game when he/she exactly reaches the date of November 4, 2001. If a player moves to a date after November 4, 2001, he/she looses the game.

Write a program that decides whether, given an initial date, Adam, the first mover, has a winning strategy.

For this game, you need to identify leap years, where February has 29 days. In the Gregorian calendar, leap years occur in years exactly divisible by four. So, 1993, 1994, and 1995 are not leap years, while 1992 and 1996 are leap years. Additionally, the years
ending with 00 are leap years only if they are divisible by 400. So, 1700, 1800, 1900, 2100, and 2200 are not leap years, while 1600, 2000, and 2400 are leap years.

 

[align=left]Input[/align]
The input consists of T test cases. The number of test cases (T) is given in the first line of the input. Each test case is written in a line and corresponds to an initial date. The three integers in a line, YYYY MM DD, represent
the date of the DD-th day of MM-th month in the year of YYYY. Remember that initial dates are randomly chosen from the interval between January 1, 1900 and November 4, 2001.

 

[align=left]Output[/align]
Print exactly one line for each test case. The line should contain the answer "YES" or "NO" to the question of whether Adam has a winning strategy against Eve. Since we have T test cases, your program should output totally T lines
of "YES" or "NO".

 

[align=left]Sample Input[/align]

3
2001 11 3
2001 11 2
2001 10 3

 

[align=left]Sample Output[/align]

YES
NO
NO

 

题目分析:
题目大意为:两个闲的DD疼的人,玩一种纠结无限的游戏,即 在1900.1.1---2001.11.4之间的日期中选定一个日期,
先到达2001.11.4则  win  
每次只能移动month   OR  day ,  BUT 如果没有下一个day,你只能移动month,(例如:2000.2.29) 
比赛从Adam开始,让你为Adam选定一个必胜的策略:
先分析一下可能win的日期: 
说明:year只决定month 2 的  day 数 ,在本题中无实质表现,一切仅有 Sum(month+day) 决定
当然还有两个特殊数据9.30 和 11.30 
Adam 
11.3
11.1
10.30
10.28
...
10.2
9.30
9.29--10.29--10.30
9.27
...
9.1
8.30
...
2.29(必输) 
2.28(必胜) 
...
12.30
...
11.30 
11.29--12.29--12.30
11.27
...
11.3
...
...
...
...
...
#include<cstdio>
int main()
{
int n,year,month,day;
scanf("%d",&n);
while(n--)
{
scanf("%d %d %d",&year,&month,&day);
if(( (month+day)%2==0) || (day==30 && month==9)|| day==30 &&month==11)
printf("YES\n");
else   printf("NO\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm 游戏 game 算法 poj