您的位置:首页 > 其它

poj 1611

2014-10-18 08:54 92 查看
The Suspects

Time Limit: 1000MS
Memory Limit: 20000K
Total Submissions: 23099
Accepted: 11217
Description
Severe acuterespiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, wasrecognized as a global threat in mid-March 2003. To minimize transmission toothers, the best strategy is to separate the suspects from others.

In the Not-Spreading-Your-Sickness University (NSYSU), there are many studentgroups. Students in the same group intercommunicate with each other frequently,and a student may join several groups. To prevent the possible transmissions ofSARS, the NSYSU collects
the member lists of all student groups, and makes thefollowing rule in their standard operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the suspects when a studentis recognized as a suspect. Your job is to write a program which finds all thesuspects.
Input
The input filecontains several cases. Each test case begins with two integers n and m in aline, where n is the number of students, and m is the number of groups. You mayassume that 0 < n <= 30000 and 0 <= m <= 500. Every student isnumbered by
a unique integer between 0 and n−1, and initially student 0 isrecognized as a suspect in all the cases. This line is followed by m memberlists of the groups, one line per group. Each line begins with an integer k byitself representing the number of members
in the group. Following the number ofmembers, there are k integers representing the students in this group. All theintegers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not beprocessed.
Output
For each case,output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1

很简单的并查集,代码如下:

#include<stdio.h>

int set[30001];

int a[30001];

int find(int x)

{

intr=x;

while(set[r]!=r)

r=set[r];

returnr;

}

void merge(int a,int b)

{

if(a<b)

set[b]=a;

else

set[a]=b;

}

int main()

{

intn,m,k,i,j,p,q,x;

while(scanf("%d%d",&n,&m)&&(n!=0||m!=0))

{

intcount=0;

for(i=0;i<n;i++)

set[i]=i;

for(i=0;i<m;i++)

{

scanf("%d",&k);

for(j=0;j<k;j++)

scanf("%d",&a[j]);

for(j=0;j<k-1;j++)

{

p=find(a[j]);

q=find(a[j+1]);

merge(p,q);

}

}

q=find(0);

for(i=0;i<n;i++)

{

p=find(i);

if(p==q)

count++;

}

printf("%d\n",count);

}

return0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: