您的位置:首页 > 其它

HDU 1028 Ignatius and the Princess III 母函数

2014-10-17 21:45 253 查看

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 13279 Accepted Submission(s): 9395



Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:

N=a[1]+a[2]+a[3]+...+a[m];

a[i]>0,1<=m<=N;

My question is how many different equations you can find for a given N.

For example, assume N is 4, we can find:

4 = 4;

4 = 3 + 1;

4 = 2 + 2;

4 = 2 + 1 + 1;

4 = 1 + 1 + 1 + 1;

so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"



Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.



Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.



Sample Input
4
10
20




Sample Output
5
42
627


/*
HDOJ 1028 母函数 

砝码:(1+x)(1+x^2)(1+x^3)(1+x^4)=1+x+x^2+2x^3+2x^4+2x^5+2x^6+2x^7+x^8+x^9+x^10 ,系数即为方案数。
x表示砝码,x的指数表示重量
都是一个的情况,例称出重量为6的物品:①、1,2,3;②、2,4两种方案。

*/ 
#include<iostream>
#include<stdio.h>
using namespace std;
// c1是保存各项质量砝码可以组合的数目
// c2是中间量,保存没一次的情况

int c1[10002],c2[10002];
int main()
{
	int i,j,k,sum;
	while(scanf("%d",&sum)!=EOF)
	{
		for(i=0;i<=sum;i++)// 首先对c1初始化,由第一个表达式(1+x+x2+..xn)初始化
		{
			c1[i]=1;
			c2[i]=0;
		}
		for(i=2;i<=sum;i++)//钱的种类数目
		{
			for(j=0;j<=sum;j++)//第j个变量 
			{
					//k表示的是第j个指数,所以k每次增i(因为第i个表达式的增量是i)
					for(k=0;k+j<=sum;k+=i)
						c2[k+j]+=c1[j];
				
			}
			for(j=0;j<=sum;j++)  
            {  
                c1[j]=c2[j];  
                c2[j]=0;  
            }
		}
		printf("%d\n",c1[sum]);	
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: