您的位置:首页 > 其它

HDU 1056 Largest Rectangle in a Histogram(dp)(求最大的矩形面积)

2014-10-17 20:07 489 查看
Problem Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of
rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:



Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned
at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.


Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn,
where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.


Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.


Sample Input
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0




Sample Output
8
4000




Source
University of Ulm Local Contest 2003



Recommend
思路:以每一行的高度为高,看左右分别可以延伸到哪里,算出面积求优解

代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
#define N 100005

__int64 h
,le
,ri
;

int main()
{
    __int64 n,i;

    while(scanf("%I64d",&n),n)
    {
        for(i=1;i<=n;i++)
        {
            scanf("%I64d",&h[i]);
            le[i]=ri[i]=i;
        }

        for(i=1;i<=n;i++)
            while(le[i]>1&&h[le[i]-1]>=h[i])
               le[i]=le[le[i]-1];

        for(i=n;i>=1;i--)
            while(ri[i]<n&&h[ri[i]+1]>=h[i])
            ri[i]=ri[ri[i]+1];

        __int64 ans=0;

        for(i=1;i<=n;i++)
        {
            __int64 temp=((ri[i]-le[i]+1)*h[i]);

            if(temp>ans)
                ans=temp;
        }

        printf("%I64d\n",ans);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: