您的位置:首页 > 其它

hdu 1718(Rank)(倒序查找,统计同一种分数的人数)

2014-10-17 17:42 218 查看

Rank

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3785 Accepted Submission(s): 1471

Problem Description
Jackson wants to know his rank in the class. The professor has posted a list of student numbers and marks. Compute Jackson’s rank in class; that is, if he has the top mark(or is tied for the top mark) his rank is 1; if he has the
second best mark(or is tied) his rank is 2, and so on.



Input
The input consist of several test cases. Each case begins with the student number of Jackson, an integer between 10000000 and 99999999. Following the student number are several lines, each containing a student number between 10000000
and 99999999 and a mark between 0 and 100. A line with a student number and mark of 0 terminates each test case. There are no more than 1000 students in the class, and each has a unique student number.



Output
For each test case, output a line giving Jackson’s rank in the class.


Sample Input
20070101
20070102 100
20070101 33
20070103 22
20070106 33
0 0




Sample Output
2




Source
2007省赛集训队练习赛(2)

题意:
班级里面的人员都是通过编号来相互区分的,给出某人的编号,求出按照成绩某人在班级里面的排名。
代码如下:
#include<stdio.h>
#include<string.h>
int a[1010];
int main()
{
	int t;
	while(~scanf("%d",&t))
	{
		int i,n,m,mark;//mark表示t表示的成绩 
		memset(a,0,sizeof(a));//初始化 
		while(~scanf("%d%d",&n,&m),(n+m))
		{
			if(n==t)//找到某人的成绩 
			{
				mark=m;
			}
			a[m]++;//用来统计某种分数的人的个数 
		}
		int sum=0;
		for(i=100;i>mark;i--)//倒叙,从满分,一直查找分数比某人高的 
		{
			sum+=a[i];
		}
		printf("%d\n",sum+1);//某人的位序,为分数大于mark的人数再加一 
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: