您的位置:首页 > 其它

HDOJ题目2844 Coins(二维多重背包)

2014-10-17 00:50 302 查看


Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 7462    Accepted Submission(s): 3040


[align=left]Problem Description[/align]
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without
change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 

[align=left]Input[/align]
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci
≤ 1000). The last test case is followed by two zeros.
 

[align=left]Output[/align]
For each test case output the answer on a single line.
 

[align=left]Sample Input[/align]

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

 

[align=left]Sample Output[/align]

8
4

 

[align=left]Source[/align]
2009 Multi-University
Training Contest 3 - Host by WHU
 

[align=left]Recommend[/align]
gaojie   |   We have carefully selected several similar problems for you:  2870 2577 2830 1505 1159 
 ac代码

多重背包,题目意思,是给n种金币的金额,金额不能超过m,然后输入每种金币的v[i],c[i]分别代表这种金币代表的金额和这种金币的数量。需要输出这些金币组合能达到不超过m的金额是多少种。

典型的二维多重背包题目。

如果采取普通的多重背包的解法,那么是O(n*m*c)

n是物品的种类数目,m是背包的容量,c是物品的每种种类相应的数目

如果应用这个题目,那么是10^7*10^3=10^10的时间复杂度,当然不可行。

当然我们可以将复杂度降到O(n*m),不过我们需要多开一个数组记录每次用物品的个数

这个题目需要求解的是能组成多少<=m的总量。

具体见代码。

#include<stdio.h>
#include<string.h>
int vis[100010],use[100010];
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)!=EOF,n||m)
{
int c[500],v[500],i,j,k,ans=0;
for(i=0;i<n;i++)
scanf("%d",&v[i]);
for(i=0;i<n;i++)
scanf("%d",&c[i]);
memset(vis,0,sizeof(vis));
memset(use,0,sizeof(use));
vis[0]=1;//注意这。。
for(i=0;i<n;i++)
{
memset(use,0,sizeof(use));
for(j=v[i];j<=m;j++)
{
if(!vis[j]&&vis[j-v[i]]&&use[j-v[i]]<c[i])
{
use[j]=use[j-v[i]]+1;
vis[j]=1;
ans++;
}
}
}
printf("%d\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: