您的位置:首页 > 其它

HDOJ题目1081 To The Max(动态规划)

2014-10-16 21:37 295 查看


To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 8370    Accepted Submission(s): 4064


[align=left]Problem Description[/align]
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in
that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0

9 2 -6 2

-4 1 -4 1

-1 8 0 -2

is in the lower left corner:

9 2

-4 1

-1 8

and has a sum of 15.

 

[align=left]Input[/align]
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated
by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers
in the array will be in the range [-127,127].

 

[align=left]Output[/align]
Output the sum of the maximal sub-rectangle.

 

[align=left]Sample Input[/align]

4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2

 

[align=left]Sample Output[/align]

15

 

[align=left]Source[/align]
Greater New York 2001
 

[align=left]Recommend[/align]
We have carefully selected several similar problems for you:  1024 1025 1080 1078 1074 
 
ac代码

#include<stdio.h>
#include<string.h>
#define max(a,b) (a>b?a:b)
//#define INF 0xfffffff
int map[1010][1010];
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
int i,j,k,ans=-1e9;
memset(map,0,sizeof(map));
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
{
int x;
scanf("%d",&x);
map[i][j]=map[i][j-1]+x;
}
}
for(i=1;i<=n;i++)
{
//int temp=-1;
for(j=1;j<=i;j++)
{
int temp=-1;
for(k=1;k<=n;k++)
{
temp=max(temp,0)+map[k][i]-map[k][j-1];
ans=max(ans,temp);
}
}
}
printf("%d\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: