您的位置:首页 > 其它

zoj 1025 || poj 1065 || hdoj1051 Wooden Sticks

2014-10-16 20:37 260 查看

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 12066    Accepted Submission(s): 5003


[align=left]Problem Description[/align]
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to
prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.

(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is
a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

 

[align=left]Input[/align]
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden
sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one
or more spaces.

 

[align=left]Output[/align]
The output should contain the minimum setup time in minutes, one per line.

 

[align=left]Sample Input[/align]

3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1

 

[align=left]Sample Output[/align]

2
1
3注意:每个木头对之后其他木头的减免效果只有1次
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
struct stick
{
int w,l;
}a[5050];
bool cmp(stick a,stick b)
{
if(a.l-b.l==0)  return a.w<b.w;
else          return a.l<b.l;
}
int main()
{
int T;
int n,i,j,L,W;
scanf("%d",&T);
while(T--)
{
int used[5050];
memset(used,0,sizeof(used));
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d %d",&a[i].l,&a[i].w);
}
sort(a,a+n,cmp);
int t=0;

//	W=a[0].w;
for(i=0;i<n;i++)
{
if(used[i]==0)
{
t++;
W=a[i].w;
L=a[i].l;
for(j=i+1;j<n;j++)
{
if(a[j].l>=L && a[j].w>=W && used[j]==0)
{
W=a[j].w;
L=a[j].l;
used[j]=1;
}
}
}

}
printf("%d\n",t);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  strlen dp poj zoj amp