您的位置:首页 > 其它

UVA 1586 ----Molar mass

2014-10-16 18:26 351 查看
这个题,走了不少弯路,做了之上2个小时,究其原因,化学功底不深厚啊。。。。。CH3这样的我还以为是(CH)3,结果。。。。。。

后来略参考了网上的代码。。

An organic compound is any member of a large class of chemical compounds whose molecules contain carbon. The molar mass of an organic compound is the mass of one
mole of the organic compound. The molar mass of an organic compound can be computed from the standard atomic weights of the elements.



When an organic compound is given as a molecular formula, Dr. CHON wants to find its molar mass. A molecular formula, such as C3 H4 O3 ,
identifies each constituent element by its chemical symbol and indicates the number of atoms of each element found in each discrete molecule of that compound. If a molecule contains more than one atom of a particular element, this quantity is indicated using
a subscript after the chemical symbol.

In this problem, we assume that the molecular formula is represented by only four elements, `C' (Carbon), `H' (Hydrogen), `O' (Oxygen), and `N' (Nitrogen) without parentheses.

The following table shows that the standard atomic weights for `C', `H', `O', and `N'.

Atomic NameCarbonHydrogenOxygenNitrogen
Standard Atomic Weight12.01 g/mol1.008 g/mol16.00 g/mol14.01 g/mol
For example, the molar mass of a molecular formula C6 H5 OH is 94.108 g/mol which is computed by 6 × (12.01 g/mol) + 6 × (1.008
g/mol) + 1× (16.00 g/mol).

Given a molecular formula, write a program to compute the molar mass of the formula.

Input

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input.
Each test case is given in a single line, which contains a molecular formula as a string. The chemical symbol is given by a capital letter and the length of the string is greater than 0 and less than 80. The quantity number n which
is represented after the chemical symbol would be omitted when the number is 1 (2

n

99) .

Output

Your program is to write to standard output. Print exactly one line for each test case. The line should contain the molar mass of the given molecular formula.

Sample Input

4
C
C6H5OH
NH2CH2COOH
C12H22O11


Sample Output

12.010
94.108
75.070
342.296


#include <stdio.h>
#include <string.h>

double M(char x)
{
if(x=='C')
return 12.01;
if(x=='H')
return 1.008;
if(x=='O')
return 16.00;
if(x=='N')
return 14.01;
}

int main()
{
char str[100];
int N,i,j;
double sum;

scanf("%d",&N);
while(N--)
{
scanf("%s",str);
sum = 0;
for(i=0; i<strlen(str); i++)
{
if(str[i]<='Z' && str[i]>='A')
{
if(str[i+1]<='9' && str[i+1]>='1')
{
if(str[i+2]<='9' && str[i+2]>='1')
{
sum = sum + M(str[i])*((str[i+1]-'0')*10 + str[i+2]-'0');
i = i+2;
}
else
{
sum = sum + M(str[i])*(str[i+1]-'0');
i++;
}
}
else
{
sum += M(str[i]);
}
}
}
printf("%.3lf\n",sum);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: