您的位置:首页 > 产品设计 > UI/UE

hdu 1159(Common Subsequence)简单dp,求出最大的公共的字符数

2014-10-16 15:48 399 查看

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 23923 Accepted Submission(s): 10567

Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing
sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of
the maximum-length common subsequence of X and Y.

The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard
output the length of the maximum-length common subsequence from the beginning of a separate line.



Sample Input
abcfbc abfcab
programming contest 
abcd mnp




Sample Output
4
2
0




Source
Southeastern Europe 2003

题意:
找到两个的字符串的最大子串中的字符的个数。
代码如下:
#include<stdio.h>
#include<string.h>
int i,j;
int c[1010][1010];//c数组用来表示对于n,m,的 两个字符串,最大公共字符数 
char a[1010],b[1010];//用来存储两个字符串 
int lcs(int n,int m)
{
	memset(c,0,sizeof(c));//初始化 
	for(i=1;i<=n;i++)
	{
		for(j=1;j<=m;j++)
		{
			if(a[i-1]==b[j-1])//两者相同的时候,就是在原来的基础上再加一 
			c[i][j]=c[i-1][j-1]+1;
			else
			c[i][j]=c[i-1][j]>c[i][j-1]?c[i-1][j]:c[i][j-1];//两者不同九江前面的两个字符串中的存储的最大的公共字符数存储在c[i][j]里 
		}
	}
	return c
[m];//返回n个字符,m个字符的最大的公共字符数 
} 
int main()
{
	while(~scanf("%s %s",a,b))
	{
		i=strlen(a);
		j=strlen(b);
		printf("%d\n",lcs(i,j));
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: