您的位置:首页 > 其它

HDU 5045(Contest-费用流)[template:费用流]

2014-10-15 09:49 393 查看

Contest

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 766 Accepted Submission(s): 341



[align=left]Problem Description[/align]
In the ACM International Collegiate Programming Contest, each team consist of three students. And the teams are given 5 hours to solve between 8 and 12 programming problems.

On Mars, there is programming contest, too. Each team consist of N students. The teams are given M hours to solve M programming problems. Each team can use only one computer, but they can’t cooperate to solve a problem. At the beginning of the ith hour, they
will get the ith programming problem. They must choose a student to solve this problem and others go out to have a rest. The chosen student will spend an hour time to program this problem. At the end of this hour, he must submit his program. This program is
then run on test data and can’t modify any more.

Now, you have to help a team to find a strategy to maximize the expected number of correctly solved problems.

For each problem, each student has a certain probability that correct solve. If the ith student solve the jth problem, the probability of correct solve is Pij .

At any time, the different between any two students’ programming time is not more than 1 hour. For example, if there are 3 students and there are 5 problems. The strategy {1,2,3,1,2}, {1,3,2,2,3} or {2,1,3,3,1} are all legal. But {1,1,3,2,3},{3,1,3,1,2} and
{1,2,3,1,1} are all illegal.

You should find a strategy to maximize the expected number of correctly solved problems, if you have know all probability

[align=left]Input[/align]
The first line of the input is T (1 ≤ T ≤ 20), which stands for the number of test cases you need to solve.

The first line of each case contains two integers N ,M (1 ≤ N ≤ 10,1 ≤ M ≤ 1000),denoting the number of students and programming problem, respectively.

The next N lines, each lines contains M real numbers between 0 and 1 , the jth number in the ith line is Pij .

[align=left]Output[/align]
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then a single real number means the maximal expected number of correctly solved problems if this team follow the best
strategy, to five digits after the decimal point. Look at the output for sample input for details.

[align=left]Sample Input[/align]

1
2 3
0.6 0.3 0.4
0.3 0.7 0.9


[align=left]Sample Output[/align]

Case #1: 2.20000


[align=left]Source[/align]
2014 ACM/ICPC Asia Regional Shanghai Online

[align=left]Recommend[/align]
hujie | We have carefully selected several similar problems for you:5065

5064
5063
5062
5061

ACM开赛在即,没有模板是决然混不下去的(Q:有模板就混得下去吗?A:Think More,,,)

So, 这是我有生之年(喂!)写得第一份模板。

说说题目,本题有n位学生和m道题,要求在任一中途时刻任2名学生做题差不超过2(防抱大腿麽,,),问解题数期望。

易证每n道题必为n位学生各做一道(1-n的全排列),故可分成ceil((double)m/(double)n),分别求即可

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<functional>
#include<iostream>
#include<cmath>
#include<cctype>
#include<ctime>
using namespace std;
#define For(i,n) for(int i=1;i<=n;i++)
#define Fork(i,k,n) for(int i=k;i<=n;i++)
#define Rep(i,n) for(int i=0;i<n;i++)
#define ForD(i,n) for(int i=n;i;i--)
#define RepD(i,n) for(int i=n;i>=0;i--)
#define Forp(x) for(int p=pre[x];p;p=next[p])
#define MAXT (200+10)
#define MAXN (2000+10)
#define MAXM (12000*2+10)
#define INF (2139062143)
#define MEM(a) memset(a,0,sizeof(a));
#define MEMI(a) memset(a,127,sizeof(a));
#define MEMi(a) memset(a,128,sizeof(a));
#define eps 1e-6
int T;
double a[10+10][1000+10];
class feiyongliu
{
public:
int n,s,t;
int q[10000];
int edge[MAXM],next[MAXM],pre[MAXN],weight[MAXM],size;
double cost[MAXM];
void addedge(int u,int v,int w,double c)
{
edge[++size]=v;
weight[size]=w;
cost[size]=c;
next[size]=pre[u];
pre[u]=size;
}
void addedge2(int u,int v,int w,double c){addedge(u,v,w,c),addedge(v,u,0,-c);}
bool b[MAXN];
double d[MAXN];
int pr[MAXN],ed[MAXN];
bool SPFA(int s,int t)
{
For(i,n) d[i]=INF;
MEM(b)
d[q[1]=s]=0;b[s]=1;
int head=1,tail=1;
while (head<=tail)
{
int now=q[head++];
Forp(now)
{
int &v=edge[p];
if (weight[p]&&d[now]+cost[p]<d[v])
{
d[v]=d[now]+cost[p];
if (!b[v]) b[v]=1,q[++tail]=v;
pr[v]=now,ed[v]=p;
}
}
b[now]=0;
}
return fabs(d[t]-INF)>eps;
}
double totcost;

double CostFlow(int s,int t)
{
while (SPFA(s,t))
{
int flow=INF;
for(int x=t;x^s;x=pr[x]) flow=min(flow,weight[ed[x]]);
totcost+=(double)flow*d[t];
for(int x=t;x^s;x=pr[x]) weight[ed[x]]-=flow,weight[ed[x]^1]+=flow;
}
return totcost;
}
void mem(int n,int t)
{
(*this).n=n;
size=1;
totcost=0;
MEM(pre) MEM(next)
}
}S;
int main()
{
//  freopen("test_contest2.in", "r", stdin);
//  freopen(".out", "w", stdout);
cin>>T;
For(t,T)
{
int n,m; //m:prob n:people
cin>>n>>m;
For(i,n)
{
For(j,m) scanf("%lf",&a[i][j]);
}
double ans=0;
For(k,m/n)
{
S.mem(m+n+2,m+n+2);
S.s=1,S.t=1+n+n+1;
For(i,n)
{
S.addedge2(1,i+1,1,0);
}
For(i,n) For(j,n) S.addedge2(1+i,1+n+j,1,-a[i][j+(k-1)*n]);
For(j,n) S.addedge2(1+n+j,S.t,1,0);
ans+=S.CostFlow(S.s,S.t);
}
if (m%n)
{
S.mem(m+n+2,m+n+2);
S.s=1,S.t=1+n+m%n+1;
For(i,n)
{
S.addedge2(1,i+1,1,0);
}
For(i,n) For(j,m%n) S.addedge2(1+i,1+n+j,1,-a[i][j+m/n*n]);
For(j,m%n) S.addedge2(1+n+j,S.t,1,0);
ans+=S.CostFlow(S.s,S.t);
}
printf("Case #%d: %.5lf\n",t,-ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: