您的位置:首页 > 其它

ZOJ 3822 Known Notation(2014牡丹江Regional K题)

2014-10-15 00:10 357 查看
题目大意:给你一个不完整的后缀表达式和两种操作,一是插入一个数或者“*”运算号,另一个是把数字和“*”交换、

一个*至少对应两个数字,而一个表达式又等于一个数字,所以相当于运算符号和数字个数相等即可(特殊情况暂且不算)。

那么对于符号数大于数字个数的情况,我们就先把数字补在最前面。(贪心的思想,因为表达式的判定方式是两个数字在前,运算符在后)

然后从前往后按对儿消去,如果运算符前面的数字或者表达式不够两个,那么就把运算符和最后面的数字调换位置即可。(看了别人的想法之后,才发现不用手动换,用栈模拟效果不错)

Known Notation

Time Limit: 2 Seconds Memory Limit: 65536 KB

Do you know reverse Polish notation (RPN)? It is a known notation in the area of mathematics and computer science. It is also known as postfix notation since every operator in an expression
follows all of its operands. Bob is a student in Marjar University. He is learning RPN recent days.
To clarify the syntax of RPN for those who haven't learnt it before, we will offer some examples here. For instance, to add 3 and 4, one would write "3 4 +" rather than "3 + 4". If there
are multiple operations, the operator is given immediately after its second operand. The arithmetic expression written "3 - 4 + 5" in conventional notation would be written "3 4 - 5 +" in RPN: 4 is first subtracted from 3, and then 5 added to it. Another infix
expression "5 + ((1 + 2) × 4) - 3" can be written down like this in RPN: "5 1 2 + 4 × + 3 -". An advantage of RPN is that it obviates the need for parentheses that are required by infix.
In this problem, we will use the asterisk "*" as the only operator and digits from "1" to "9" (without "0") as components of operands.
You are given an expression in reverse Polish notation. Unfortunately, all space characters are missing. That means the expression are concatenated into several long numeric sequence
which are separated by asterisks. So you cannot distinguish the numbers from the given string.
You task is to check whether the given string can represent a valid RPN expression. If the given string cannot represent any valid RPN, please find out the minimal number of operations
to make it valid. There are two types of operation to adjust the given string:

Insert. You can insert a non-zero digit or an asterisk anywhere. For example, if you insert a "1" at the beginning of "2*3*4", the string becomes "12*3*4".
Swap. You can swap any two characters in the string. For example, if you swap the last two characters of "12*3*4", the string becomes "12*34*".

The strings "2*3*4" and "12*3*4" cannot represent any valid RPN, but the string "12*34*" can represent a valid RPN which is "1 2 * 34 *".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:
There is a non-empty string consists of asterisks and non-zero digits. The length of the string will not exceed 1000.

Output

For each test case, output the minimal number of operations to make the given string able to represent a valid RPN.

Sample Input

3
1*1
11*234**
*

Sample Output

1
0
2


Author: CHEN, Cong

Source: The 2014 ACM-ICPC Asia Mudanjiang Regional Contest
#include <iostream>
#include <cstdio>
#include <stack>
#include <cstring>
#include <string>
using namespace std;
#define MAXN 5000
char ch[MAXN];
int t, n, n1, n2, ans;
int main() {
scanf("%d", &t);
while(t--) {
string str;
stack<int> sta;//记录所有数字下标,用于交换操作
scanf("%s", ch);
n1 = 0, n2 = 0;
for(int i = 0; i < strlen(ch); i++)
if(ch[i] == '*') n2++;
else n1++;
if(n2 == 0)
{printf("0\n"); goto loop;}
for(int i = 0; i <= n2 - n1; i++) str += "1";
str += ch;
for(int i = 0; i < str.length(); i++)
if(str[i] != '*') sta.push(i);
n = 0, ans = max(n2 - n1 + 1, 0);
for(int i = 0; i < str.length(); i++) {
if(str[i] == '*') {
if(n < 2) {
str[sta.top()] = '*';
sta.pop();
n++; ans++;
} else n--;
} else n++;
}
if(ans == 0 && str[str.length() - 1] != '*') ans = 1;
printf("%d\n", ans);
loop:;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: