您的位置:首页 > 其它

poj 3077 Rounders

2014-10-14 20:20 267 查看
Rounders

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 7656Accepted: 4961
Description

For a given number, if greater than ten, round it to the nearest ten, then (if that result is greater than 100) take the result and round it to the nearest hundred, then (if that result is greater than 1000) take that number and round it to the nearest thousand,
and so on ...
Input

Input to this problem will begin with a line containing a single integer n indicating the number of integers to round. The next n lines each contain a single integer x (0 <= x <= 99999999).
Output

For each integer in the input, display the rounded integer on its own line.

Note: Round up on fives.
Sample Input
9
15
14
4
5
99
12345678
44444445
1445
446

Sample Output
20
10
4
5
100
10000000
50000000
2000
500


题目意思:给你一个数字,按照它给的规则求出它的近似数;规则:对于445,先转化为450,再转化为500;对于123456,》123460》123500》12400》12000》10000;

#include <iostream>
using namespace std;
int main(){
int t,n,num[10];
cin>>t;
while (t--){
cin>>n;
if (n<=10)
cout<<n<<endl;
else{
int k=0;
while (n>0){
num[k++]=n%10;
n/=10;
}
for (int i=0;i<k-1;i++){
if (num[i]>=5)
num[i+1]++;
num[i]=0;
}
while (k--)
cout<<num[k];
cout<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: