您的位置:首页 > 产品设计 > UI/UE

POJ 1458 && HDU 1159 Common Subsequence (最長公共子序列)dp

2014-10-13 13:57 417 查看
鏈接:http://poj.org/problem?id=1458

Description:

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly
increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to
find the length of the maximum-length common subsequence of X and Y.

Input:

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output:

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input:

abcfbc abfcab
programming contest
abcd mnp

Sample Output:

4
2
0

分析:(LCS算法)

给定一个序列Xm = (x1, x2, …, xm),我们定义Xm的第i个前缀为:

Xi = ( x1, x2, …, xi ) i = 0, 1, 2, …, m

c[i, j]为序列Xi = (x1, x2, …, xi)和Yj = (y1, y2, …, yj)的最长公共子序列的长度.

设序列Xm={x1,x2,…,xm}和Yn={y1,y2,…,yn}的一个最长公共子序列为Zk={z1,z2,…,zk},则

1.若xm=yn,

则zk=xm=yn,且Zk-1是Xm-1和Yn-1的最长公共子序列。

2.若xm≠yn,且zk≠xm,

则Zk是Xm-1和Yn的最长公共子序列。

3.若xm≠yn,且zk≠ yn ,

则Zk是Xm和Yn-1的最长公共子序列。

代碼:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#define MAXN 1010
#define RST(N)memset(N, 0, sizeof(N))
using namespace std;

char s1[MAXN], s2[MAXN];
int lcs[MAXN][MAXN], L1, L2;

int max(int x, int y) { return x > y ? x : y; }

int LCS()
{
L1 = strlen(s1+1), L2 = strlen(s2+1);
for(int i=0; i<=L1; i++) lcs[i][0]=0;
for(int i=0; i<=L2; i++) lcs[0][i]=0;
for(int i=1; i<=L1; i++) {
for(int j=1; j<=L2; j++) {
if(s1[i] == s2[j]) lcs[i][j]=lcs[i-1][j-1]+1;
else lcs[i][j]=max(lcs[i-1][j], lcs[i][j-1]);
}
}
return lcs[L1][L2];
}

int main()
{
while(~scanf("%s %s", s1+1, s2+1)) {
printf("%d\n", LCS());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息