您的位置:首页 > 其它

Find your present!(杭电1563)

2014-10-12 17:31 323 查看


Find your present!

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2742 Accepted Submission(s): 1815



Problem Description

In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number
will be the one that different from all the others.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.



Input

The input file will consist of several cases.

Each case will be presented by an integer n (1<=n<=200, and n is odd) at first. Following that, n positive integers will be given in a line. These numbers indicate the card numbers of the presents.n = 0 ends the input.



Output

For each case, output an integer in a line, which is the card number of your present.



Sample Input

5
1 1 3 2 2
3
1 2 1
0




Sample Output

3
2//方法一:排序法 
#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
    int s[202];
    int i,j,n,t=0;
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        for(i=0;i<n;i++)
        {
            scanf("%d",&s[i]);
        }
        sort(s,s+n);
        if(s[0]<s[1])
        printf("%d\n",s[0]);
        if(s[n-1]>s[n-2])
        printf("%d\n",s[n-1]);
        for(i=1;i<n-1;i++)
        {
            if(s[i-1]<s[i]&&s[i]<s[i+1])
            {
                printf("%d\n",s[i]);
                break;
            }
        }
    }
     return 0;
}
//方法二:直接法,巧妙。 
#include<stdio.h>
#include<string.h>
int s[1000000]={0};
int main()
{
    int n,i;
    int a[202];
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        memset(s,0,sizeof(s));
        for(i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            s[a[i]]++;
        }
        for(i=0;i<n;i++)
        {
            if(s[a[i]]==1)
            {
               printf("%d\n",a[i]);
               break;
            }
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: