您的位置:首页 > 其它

poj 1269 zoj 1280 Intersecting Lines

2014-10-12 10:10 405 查看
Intersecting Lines

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 11276Accepted: 5090
Description

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they
are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect.

Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000.

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4.
Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).
Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point.
If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".

Sample Input
5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output
INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT

题目意思:给出两条直线(4个点),要求判断出这两条直线的关系:平行,同线,相交。如果相交还要求出交点坐标;
解题思路:分类讨论,先考虑二者斜率均有的情况,然后再考虑其中之一有斜率,最后考虑均无斜率的情况;
#include <iostream>
#include <iomanip>
using namespace std;
struct line{
double x1,y1,x2,y2;
}l[3];
bool istrue(line a,double x,double y){
if ((a.x1<=x&&x<=a.x2||a.x1>=x&&x>=a.x2) && (a.y1<=y&&y<=a.y2||a.y1>=y&&y>=a.y2))
return true;
return false;
}
int main(){
int n;
cin>>n;
cout<<"INTERSECTING LINES OUTPUT"<<endl;
while (n--){
for (int i=0;i<2;i++)
cin>>l[i].x1>>l[i].y1>>l[i].x2>>l[i].y2;
if (l[0].x1!=l[0].x2 && l[1].x1!=l[1].x2){		//均有斜率的两条线段
double k1=(l[0].y2-l[0].y1)/(l[0].x2-l[0].x1),k2=(l[1].y2-l[1].y1)/(l[1].x2-l[1].x1);
double b1=-k1*l[0].x1+l[0].y1,b2=-k2*l[1].x1+l[1].y1;
//cout<<"k1="<<k1<<" k2="<<k2<<endl;
if (k1==k2){	//共线或者平行
if (k1*l[1].x1+b1==l[1].y1)
cout<<"LINE"<<endl;
else
cout<<"NONE"<<endl;
}
else{
double x=(b2-b1)/(k1-k2),y=k1*x+b1;
//cout<<"x="<<x<<" y="<<y<<endl;
if (istrue(l[0],x,y)==true && istrue(l[1],x,y)==true)	//有交点且在线段内
cout<<"POINT "<<fixed<<setprecision(2)<<x<<" "<<y<<endl;
else	//无交点或者有交点但不在线段内
cout<<"NONE"<<endl;
}
}
else{
if (l[0].x1!=l[0].x2 && l[1].x1==l[1].x2){	//其中一条线段无斜率
double k1=(l[0].y2-l[0].y1)/(l[0].x2-l[0].x1);
double b1=-k1*l[0].x1+l[0].y1;
double x=l[1].x1,y=k1*x+b1;
if (istrue(l[0],x,y)==true && istrue(l[1],x,y)==true)
cout<<"POINT "<<fixed<<setprecision(2)<<x<<" "<<y<<endl;
else
cout<<"NONE"<<endl;
}
else{
if (l[0].x1==l[0].x2 && l[1].x1!=l[1].x2){	//其中一条线段无斜率
double k2=(l[1].y2-l[1].y1)/(l[1].x2-l[1].x1);
double b2=-k2*l[1].x1+l[1].y1;
double x=l[0].x1,y=k2*x+b2;
if (istrue(l[0],x,y)==true && istrue(l[1],x,y)==true)
cout<<"POINT "<<fixed<<setprecision(2)<<x<<" "<<y<<endl;
else
cout<<"NONE"<<endl;
}
else{	//均无斜率
if (l[0].x1==l[1].x2)
cout<<"LINE"<<endl;
else
cout<<"NONE"<<endl;
}
}
}
}
cout<<"END OF OUTPUT"<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: