您的位置:首页 > 其它

poj-2318--TOYS(求叉积)

2014-10-07 15:57 239 查看
TOYS

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 10637Accepted: 5114
Description

Calculate the number of toys that land in each bin of a partitioned toy box.

Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the
toys get mixed up, and it is impossible for John to find his favorite toys.

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example
toy box.



For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.
Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner
and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that
the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is
random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.
Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the
rightmost bin). Separate the output of different problems by a single blank line.
Sample Input
5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output
0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.
Source
Rocky Mountain 2003

#include<stdio.h>
#include<string.h>
#include<math.h>
#define MAXN 5005
const double epsi=1e-10;
inline int	sign(const double &x);
inline double sqr(const double &x);

struct Point{
double x,y;

Point(double _x=0,double _y=0):x(_x),y(_y){
}
Point operator +(const Point &op2) const{
return Point(x+op2.x,y+op2.y);
}

Point operator -(const Point &op2) const{
return Point(x-op2.x,y-op2.y);
}
double operator ^(const Point &op2) const{
return x*op2.y-y*op2.x;
}
double operator *(const Point &op2) const{
return x*op2.x+y*op2.y;
}
Point operator *(const double &d) const{
return Point(x*d,y*d);
}
Point operator /(const double &d) const{
return Point(x/d,y/d);
}

bool operator ==(const Point &op2) const{
return sign(x-op2.x)==0&&sign(y-op2.y)==0;
}

};

inline int	sign(const double &x){
if(x>epsi) return 1;//>0
if(x<-epsi) return -1;//<0
return 0;
}

inline double mul(const Point &p0,const Point &p1,const Point &p2){//p0p1与p0p2叉积
return (p1-p0)^(p2-p0);
}
inline double sqr(const double &x){
return x*x;
}
inline double dis2(const Point &p0,const Point &p1){//p0p1平方
return sqr(p0.x-p1.x)+sqr(p0.y-p1.y);
}
inline double dis(const Point &p0,const Point &p1){//p0p1
return sqrt(dis2(p0,p1));
}

struct Line
{
Point s,e;
Line(){}
Line(Point _s,Point _e)
{
s = _s;e = _e;
}
};

Point toy,st,en;
Line linep[MAXN];
int toys[MAXN];
int main(){
int n,m,x1,y1,x2,y2,Ui,Li;
while(~scanf("%d",&n),n){
scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);
for(int i=0;i<n;i++){
scanf("%d%d",&Ui,&Li);
//			st.x=Ui;st.y=y1;
//			en.x=Li;en.y=y2;
linep[i]=Line(Point(Ui,y1),Point(Li,y2));
//			linep[i].s=st;
//			linep[i].e=en;
}
linep
=Line(Point(x2,y1),Point(x2,y2));
memset(toys,0,sizeof(toys));
while(m--){
int x,y,now;
now=0;
scanf("%d%d",&x,&y);
toy=Point(x,y);
for(int i=0;i<=n;i++){
if(mul(linep[i].s,linep[i].e,toy)<0){
now=i;break;
}

}
toys[now]++;
}
for(int i=0;i<=n;i++)
printf("%d: %d\n",i,toys[i]);
printf("\n");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: