您的位置:首页 > 其它

HDU 3047 Zjnu Stadium(带权并查集,路径压缩)

2014-10-05 00:08 381 查看

Zjnu Stadium

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1675 Accepted Submission(s): 630



Problem Description

In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The
total number of columns were 300 numbered 1--300, counted clockwise, we assume the number of rows were infinite.

These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered
B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).

Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests
and count them as R.



Input

There are many test cases:

For every case:

The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.

Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.



Output

For every case:

Output R, represents the number of incorrect request.



Sample Input

10 10
1 2 150
3 4 200
1 5 270
2 6 200
6 5 80
4 7 150
8 9 100
4 8 50
1 7 100
9 2 100


Sample Output

2
Hint
Hint:
(PS: the 5th and 10th requests are incorrect)
 题目大意:题目鬼扯了很长, 大致意思可以理解为有N个点,每个点的初始位置为0,每行给3个数,x,y,z,y在x的右边距离为z处,相对距离,最后问有几个矛盾的陈述,只用到一个简单的路径压缩,还有很多并查集要用到这个题目链接:点击打开链接代码注释:
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
#define N 50005
int f
,pos
;
int n,ans;
int find(int x)
{
if(x==f[x])
return f[x];
int tem=f[x];
f[x]=find(tem);
pos[x]+=pos[tem];
return f[x];
}
void init()
{
for(int i=1; i<=n; i++)
{
f[i]=i;
pos[i]=0;
}
ans=0;
}
void make(int x,int y,int dis)
{
int a=find(x);
int b=find(y);
if(a==b)
{
if(pos[y]-pos[x]!=dis)
ans++;
}
else
{
f[b]=a;
pos[b]=pos[x]+dis-pos[y];
}
}
int main()
{
int m;
while(cin>>n>>m)
{
init();
while(m--)
{
int x,y,s;
scanf("%d%d%d",&x,&y,&s);
make(x,y,s);
}
cout<<ans<<endl;
}
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: