您的位置:首页 > 其它

POJ 3046 - Ant Counting(dp多种背包变型)

2014-10-03 21:42 519 查看
Description
Bessie was poking around the ant hill one day watching the ants march to and fro while gathering food. She realized that many of the ants were siblings, indistinguishable from one another. She also realized the sometimes only one
ant would go for food, sometimes a few, and sometimes all of them. This made for a large number of different sets of ants!

Being a bit mathematical, Bessie started wondering. Bessie noted that the hive has T (1 <= T <= 1,000) families of ants which she labeled 1..T (A ants altogether). Each family had some number Ni (1 <= Ni <= 100) of ants.

How many groups of sizes S, S+1, ..., B (1 <= S <= B <= A) can be formed?

While observing one group, the set of three ant families was seen as {1, 1, 2, 2, 3}, though rarely in that order. The possible sets of marching ants were:

3 sets with 1 ant: {1} {2} {3}

5 sets with 2 ants: {1,1} {1,2} {1,3} {2,2} {2,3}

5 sets with 3 ants: {1,1,2} {1,1,3} {1,2,2} {1,2,3} {2,2,3}

3 sets with 4 ants: {1,2,2,3} {1,1,2,2} {1,1,2,3}

1 set with 5 ants: {1,1,2,2,3}

Your job is to count the number of possible sets of ants given the data above.

Input
* Line 1: 4 space-separated integers: T, A, S, and B

* Lines 2..A+1: Each line contains a single integer that is an ant type present in the hive
Output
* Line 1: The number of sets of size S..B (inclusive) that can be created. A set like {1,2} is the same as the set {2,1} and should not be double-counted. Print only the LAST SIX DIGITS of this number, with no leading zeroes or
spaces.
Sample Input
3 5 2 3
1
2
2
1
3

Sample Output
10

Hint
INPUT DETAILS:

Three types of ants (1..3); 5 ants altogether. How many sets of size 2 or size 3 can be made?

OUTPUT DETAILS:

5 sets of ants with two members; 5 more sets of ants with three members

                                                                           

题意:

给出A (1 <=A <= 100)个T (1 <= T <= 1,000)范围内的数,求出从S 到B 个数的组合有多少种。

思路:

DP,多重背包。状态方程dp[i][j] 指的是前i种数构成长度为j的序列有几种。

由于dp每次都是 i 和 i -1,所以可以使用滚动数组。注意使用滚动数组的时候前一个状态应该清 0 。

CODE:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <string>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#include <set>
#include <map>
const int inf=0xfffffff;
typedef long long ll;
using namespace std;
const int mod = 1e6;
int n[1005];
int dp[2][100005];

int main()
{
//freopen("in", "r", stdin);
int t, a, s, b;
while(~scanf("%d %d %d %d", &t, &a, &s, &b)){
memset(dp, 0, sizeof(dp));
memset(n, 0, sizeof(n));
for(int i = 0;i < a; i ++){
int num;
scanf("%d", &num);
n[num]++;
}
dp[0][0] = 1;
for(int i = 1; i <= t; i ++){
int cur = i & 1;
int pre = (i - 1) & 1;
memset(dp[cur], 0, sizeof(dp[cur]));
for(int k = 0; k <= n[i]; k ++){
for(int j = 0; j <= b; j ++){
if(j >= k) dp[cur][j] = (dp[cur][j] + dp[pre][j - k]) % mod;
}
}
}
int sum = 0;
int cur = t & 1;
for(int i = s; i <= b; i ++){
sum = (sum + dp[cur][i]) % mod;
}
printf("%d\n", sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  POJ DP