您的位置:首页 > 产品设计 > UI/UE

高精度-Children’s Queue

2014-10-03 11:58 363 查看


Children’s Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 10732    Accepted Submission(s): 3468


Problem Description

There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side.
The case n=4 (n is the number of children) is like

FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM

Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?

 

Input

There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)

 

Output

For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.

 

Sample Input

1
2
3

 

Sample Output

1
2
4

 
代码:
#include <iostream>
#include <cstdio>
using namespace std;
int a[1005][1005]={0};
int main()
{

a[1][0]=1;
a[2][0]=2;
a[3][0]=4;
a[4][0]=7;
int t[1000+5];
t[1]=1;
t[2]=1;
t[3]=1;
t[4]=1;
int j,i;
for(i=5;i<1001;i++)
{
t[i]=t[i-1];
int h=0;
int m;
for(j=0;j<t[i];j++)
{
m=a[i-1][j]+a[i-2][j]+a[i-4][j]+h;
a[i][j]=m%10;
h=m/10;

}

while(h)
{
a[i][t[i]]=h%10;
t[i]++;
h=h/10;

}

}
int n;
while(scanf("%d",&n)!=EOF)
{
int i1;
for(i1=t
-1;i1>=0;i1--)
cout<<a
[i1];
cout<<endl;

}
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: