您的位置:首页 > 其它

hdu 1814 Peaceful Commission 2-sat 按字典序输出

2014-10-02 21:35 337 查看


Peaceful Commission

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1957 Accepted Submission(s): 561



Problem Description

The Public Peace Commission should be legislated in Parliament of The Democratic Republic of Byteland according to The Very Important Law. Unfortunately one of the obstacles is the fact that some deputies do not get on with some others.

The Commission has to fulfill the following conditions:

1.Each party has exactly one representative in the Commission,

2.If two deputies do not like each other, they cannot both belong to the Commission.

Each party has exactly two deputies in the Parliament. All of them are numbered from 1 to 2n. Deputies with numbers 2i-1 and 2i belong to the i-th party .

Task

Write a program, which:

1.reads from the text file SPO.IN the number of parties and the pairs of deputies that are not on friendly terms,

2.decides whether it is possible to establish the Commission, and if so, proposes the list of members,

3.writes the result in the text file SPO.OUT.



Input

In the first line of the text file SPO.IN there are two non-negative integers n and m. They denote respectively: the number of parties, 1 <= n <= 8000, and the number of pairs of deputies, who do not like each other, 0 <= m <=2 0000. In each of the following
m lines there is written one pair of integers a and b, 1 <= a < b <= 2n, separated by a single space. It means that the deputies a and b do not like each other.

There are multiple test cases. Process to end of file.



Output

The text file SPO.OUT should contain one word NIE (means NO in Polish), if the setting up of the Commission is impossible. In case when setting up of the Commission is possible the file SPO.OUT should contain n integers from the interval from 1 to 2n, written
in the ascending order, indicating numbers of deputies who can form the Commission. Each of these numbers should be written in a separate line. If the Commission can be formed in various ways, your program may write mininum number sequence.



Sample Input

3 2
1 3
2 4




Sample Output

1
4
5


题意,n个党参加会议,每个党有两个人编号2*n-1, 2*n。 其中m对人敌视。如果每个党派必须有且仅有个人参加,而且参加的人中没互相敌视的。如果可以,输出n个参加的人的编号,不行的话输出NIE。

#include<stdio.h>
#include<string.h>
#include<map>
#include<algorithm>
using namespace std;
#define N 18000//点数 得是原来点数的两倍
#define M 80006//边数 

struct Edge{
	int to, nex;
}edge[M];
//注意 N M 要修改
int head
, edgenum;
void addedge(int u, int v){
	Edge E = {v, head[u]};
	edge[edgenum] = E;
	head[u] = edgenum ++;
}

bool mark
;
int Stack
, top;
void init(){
	memset(head, -1, sizeof(head)); edgenum = 0;
	memset(mark, 0, sizeof(mark));
}

bool dfs(int x)
{
	if(mark[x^1])return false;//一定是拆点的点先判断
	if(mark[x])return true;

	mark[x] = true;
	Stack[top++] = x;//把假设都 存下来

	for(int i = head[x]; i != -1; i = edge[i].nex)
		if(!dfs(edge[i].to)) return false;
	return true;
}

bool solve(int n){
	for(int i = 0; i < 2 * n; i+=2)
		if(!mark[i] && !mark[i^1])
		{
			top = 0;
			if(!dfs(i))//如果假设当前这个成立,是否会和之前已经确定的取否关系发生矛盾。
			{
				while( top ) mark[ Stack[--top] ] = false;//如果矛盾,把前面假设来使i事件成立的那些条件全部反悔掉。
				if(!dfs(i^1)) return false;//然后i事件的对立面 假设成立,如果条件仍无法满足,直接返回
			}
		}
	return true;
} 

int main()
{
	int n,m,tem,u,v;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		init();
		for(int i=0;i<m;i++)
		{
			scanf("%d%d",&u,&v);
			u--;
			v--;
			addedge(u,v^1);
			addedge(v,u^1);
		}
		if(solve(n))
		{
		    for(int i=0;i<2*n;i++)
			{
				if(mark[i])
					printf("%d\n",i+1);
			} 
		}
		else
			puts("NIE");
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: