您的位置:首页 > 其它

COURSES - POJ 1469 二分图匹配

2014-10-01 20:08 330 查看
COURSES

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 17710Accepted: 6988
Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

every student in the committee represents a different course (a student can represent a course if he/she visits that course)

each course has a representative in the committee

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format:

P N

Count1 Student1 1 Student1 2 ... Student1 Count1

Count2 Student2 1 Student2 2 ... Student2 Count2

...

CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P,
each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each
two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.
Sample Input
2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output
YES
NO


题意:问是否存在每个课对一个不同的学生的情况。

思路:最简单的二分图匹配。

AC代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
int g[110][310],flag,vis[310];
int match[310],p,n;
bool dfs(int u)
{
    int i,j,k;
    for(i=1;i<=n;i++)
       if(g[u][i] && !vis[i])
       {
           vis[i]=1;
           if(match[i]==-1 || dfs(match[i]))
           {
               match[i]=u;
               return true;
           }
       }
    return false;
}
int main()
{
    int T,t,i,j,k,v,ans;
    scanf("%d",&T);
    for(t=1;t<=T;t++)
    {
        scanf("%d%d",&p,&n);
        for(i=1;i<=p;i++)
           for(j=1;j<=n;j++)
              g[i][j]=0;
        for(i=1;i<=n;i++)
           match[i]=-1;
        flag=1;
        for(i=1;i<=p;i++)
        {
            scanf("%d",&k);
            if(k==0)
              flag=0;
            while(k--)
            {
                scanf("%d",&v);
                g[i][v]=1;
            }
        }
        if(flag)
        {
            ans=0;
            for(i=1;i<=p;i++)
            {
                memset(vis,0,sizeof(vis));
                if(dfs(i))
                  ans++;
            }
            if(ans==p)
              printf("YES\n");
            else
              printf("NO\n");
        }
        else
          printf("NO\n");
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: