您的位置:首页 > 其它

Big Christmas Tree - POJ 3013 spfa

2014-10-01 16:14 381 查看
Big Christmas Tree

Time Limit: 3000MSMemory Limit: 131072K
Total Submissions: 20940Accepted: 4526
Description


Christmas is coming to KCM city. Suby the loyal civilian in KCM city is preparing a big neat Christmas tree. The simple structure of the tree is shown in right picture.

The tree can be represented as a collection of numbered nodes and some edges. The nodes are numbered 1 through n. The root is always numbered 1. Every node in the tree has its weight. The weights can be different from each other. Also the shape
of every available edge between two nodes is different, so the unit price of each edge is different. Because of a technical difficulty, price of an edge will be (sum of weights of all descendant nodes) × (unit price of the edge).

Suby wants to minimize the cost of whole tree among all possible choices. Also he wants to use all nodes because he wants a large tree. So he decided to ask you for helping solve this task by find the minimum cost.

Input

The input consists of T test cases. The number of test cases T is given in the first line of the input file. Each test case consists of several lines. Two numbers v, e (0 ≤ v, e ≤ 50000) are given in
the first line of each test case. On the next line, v positive integers wi indicating the weights of v nodes are given in one line. On the following e lines, each line contain three positive integers a, b, c indicating
the edge which is able to connect two nodes a and b, and unit price c.

All numbers in input are less than 216.

Output

For each test case, output an integer indicating the minimum possible cost for the tree in one line. If there is no way to build a Christmas tree, print “No Answer” in one line.

Sample Input
2
2 1
1 1
1 2 15
7 7
200 10 20 30 40 50 60
1 2 1
2 3 3
2 4 2
3 5 4
3 7 2
3 6 3
1 5 9

Sample Output
15
1210


题意:每一个边的花费是它的所有节点的重量乘以这条边的权值,问组合后的最小花费。

思路:spfa将每条边的权值看做是距离,然后最终花费是每个节点的重量乘以到1节点的距离。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
typedef long long ll;
struct node
{
    int y,w,next;
}e[100010];
int n,m,h[50010],tot;
ll W[50010],d[50010],ans,INF=1000000000000000LL;
bool vis[50010];
queue<int> qu;
void ins(int x,int y,int w)
{
    e[++tot].y=y;
    e[tot].w=w;
    e[tot].next=h[x];
    h[x]=tot;
}
void spfa(int s)
{
    int i,j,k,x,y;
    qu.push(s);
    memset(vis,0,sizeof(vis));
    vis[s]=1;
    for(i=1;i<=n;i++)
       d[i]=INF;
    d[s]=0;
    while(!qu.empty())
    {
        x=qu.front();
        qu.pop();
        for(i=h[x];i;i=e[i].next)
        {
            y=e[i].y;
            if(d[x]+e[i].w<d[y])
            {
                d[y]=d[x]+e[i].w;
                if(!vis[y])
                {
                    vis[y]=1;
                    qu.push(y);
                }
            }
        }
        vis[x]=0;
    }
}
int main()
{
    int T,t,i,j,k,u,v;
    bool flag;
    scanf("%d",&T);
    for(t=1;t<=T;t++)
    {
        scanf("%d%d",&n,&m);
        for(i=1;i<=n;i++)
           scanf("%I64d",&W[i]);
        tot=0;
        memset(h,0,sizeof(h));
        for(i=1;i<=m;i++)
        {
            scanf("%d%d%d",&u,&v,&k);
            ins(u,v,k);
            ins(v,u,k);
        }
        spfa(1);
        ans=0;
        flag=true;
        for(i=1;i<=n;i++)
           if(d[i]==INF)
             flag=false;
        if(flag)
        {
            for(i=1;i<=n;i++)
               ans+=d[i]*W[i];
            printf("%I64d\n",ans);
        }
        else
           printf("No Answer\n");

    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: